Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I installed Redhat 9 and everything went just great.I got it to dual boot with windows too.But linux does not recognize my modem.That is the sole problem.I use a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Posts
    8

    Woes with modem detection.HELP!!


    Hello,

    I installed Redhat 9 and everything went just great.I got it to dual boot with windows too.But linux does not recognize my modem.That is the sole problem.I use a telephone line to dial into my ISP(America On Line) and linux would not recognize my modem

    Everything was working fine until I tried to manually set it up and now when I boot, the booting stops when it tries to set the network parameters.

    I get the folloiwng messages

    Setting network parameters [OK]
    Bringing up loopback interface [OK]
    Bringing up interface ppp0 :

    At the last above message , it just waits for user input and then it does not proceed,I have tried providing every parameter.Does any one know what exactly does it expect here
    How do I get past this and get linux to boot successfully?.Any pointers???

    Thanks

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    what kind of modem is it?
    is it a winmodem?

    see my guide on the post installation page for more details


    also, I think if you use AOL, it has to be set up differently somehow, you might have to do some further research.

    let me know

  3. #3
    Just Joined!
    Join Date
    Jun 2003
    Posts
    8
    Hi,
    Thanks a lot for your response.But I am in a soup now.I am not able to complete booting now.It just displays the following messages

    Setting network parameters [OK]
    Bringing up loopback interface [OK]
    Bringing up interface ppp0 :

    and then waits for user input at the last message. I have tried hitting all keys on the keyboard and it just will not boot from that point on.It just accepts whatever I type in and the booting never continues from that point.I have to reboot the machine and it again stops at the same point where it expects a user input.

    How can I get the booting to continue.Appreciate your help.

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The first thing that you can do is to disable ppp0 from loading on boot. I'm guessing that you don't really want to dial your ISP every time you boot anyway, right? First, boot the system into single user mode. For information on how to do that, see this old post. That post describes how to boot into runlevel 3 instead of runlevel 5. You will need to boot into runlevel 1, so replace all the 3's with 1's.
    When you have a shell, start a text editor (You have plenty to choose from, but I don't know which you installed. Choose between the standard ones: pico, nano, joe, emacs, vi, etc. vi is a bit hard to use, so if that's the only one that you have installed, run vimtutor first to learn how to use it). Start it as "editor /etc/sysconfig/network-scripts/ifcfg-ppp0", where you should substitute "editor" with an editor that you do have installed. Once you have that file open, look for the line "ONBOOT=yes", and replace it with "ONBOOT=no". Then you can reboot your system with the "reboot" command, and boot it up normally.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •