Find the answer to your Linux question:
Results 1 to 6 of 6
Hi there, I am in a process of installing Ubuntu Linux in my laptop (actually dual booting it with windows xp - sp2 ). When I finish installing Ubuntu, and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Vancouver, BC
    Posts
    20

    hard drive boot sector invalid


    Hi there,

    I am in a process of installing Ubuntu Linux in my laptop (actually dual booting it with windows xp - sp2 ). When I finish installing Ubuntu, and rebooting my system, I get the following error message:

    hard drive boot sector invalid. press h for hard drive or any key for floppy.

    The only thing I remember is that I installed GRUB on the master boot record. If anyone knows how to fix this problem, please please reply to message. Thank you in advance.

    Young

    P.S. I also want to know the following. During the hdd partitioning process, I get to choose for each partion (/, /boot., and other options). I want to know what /boot does.

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    Young,
    there is a tutorial on grub in this forum (http://www.linuxforums.org/forum/topic-19999.html) which may help, but I certainly don't recognize the error message that you have.

    All I can suggest is that you either use the install CD to boot from to see if you can rescue the situation or follow the instructions in the above tutorial to create a grub diskette to boot from.

    Once you've booted I suggest that you attempt to re-instal grub (again explained in the tutorial). If the worse comes to the worse you can always follow a different tutorial to put WinXP back on your master boot record.


    As to your other question. The "/" also known as the root partition (but not to be confused with your root user) has most of linux on it. The "/boot" partition has the kernels and grub stuff on it (you can, if you wish, have this as a folder in the "/" partition instead of being a partition of its own). Not sure why or from where the separate /boot partition comes from. I suspect that it's down to keeping your precious kernels safe from problems that may occur on you "/" partition. There may also be a swap partition (normally 2 to 2 and a half times the ize of the PC's RAM) which is there for the swapper file (same purpose as Windows' SWAPPER.DAT).

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Location
    Vancouver, BC
    Posts
    20

    thank you

    Hello Nerdello,

    Thanx a million, I managed to fix the problem last night. But anyhow thank you for replying.

    Cheers,
    Young

  4. #4
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157

    Re: thank you

    Quote Originally Posted by Young
    I managed to fix the problem last night
    Do you mind posting how you fixed the problem so others with the same problem will be able to fix it?

    cheers;

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Location
    Vancouver, BC
    Posts
    20

    thanx for the reminder

    Hello there,

    Of course, I nearly fogot. Thank you for reminding me.

    Basically what I did is bit of trial and error. I had to reinstall the OS
    couple of times to actually figure this out.

    My hard drive is divided into three partitions:

    a) parition for linux (10GB)
    b) swap partition (2GB)
    c) windows partition (28 GB)

    For a) I configure it so that i would have ext3 and configure it as root partition. I also made sure that the boot flag was on instead of being off (I basically turned on the boot flag for all the partition, and I think this is something that fixed the problem. Not too sure at the moment). For b), I adjusted so that it actually is the swap partition. Oh by the way, there are menus for each partition during the partitioning procedure (simple highlight the partion, and press enter- you'll see more menus and just highlight them and hit enter as well for those-some of them have submenus), And then basically, I installed the GRUB in master boot record. That's about it I think. The really important part of the whole ordeal I think, is that the boot flag for all the partition is on, and check your BIOS and make sure that you're running the system from the HDD.

    If anyone knows hundred precent sure about fixing the problem, I would be more happy to hear about it. I am just a newb, and as I said, it was basically trial and error.

    Young

  6. #6
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Thanks Young
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •