Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
I installed (nearli successfully) ubuntu in one of my laptop partition. I also have windowsxp and I'm using Grub as bootloader. But there is still a problem. When I logout ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    16

    boot problem


    I installed (nearli successfully) ubuntu in one of my laptop partition.
    I also have windowsxp and I'm using Grub as bootloader.
    But there is still a problem.
    When I logout from Ubuntu and restart the computer to pass at windows, windows boots up but I can't login! And I can't neither turn off the machine. Then I swith off the power and start again windows. It obviously checks the disk and just then I can login.
    This happens every time I pass from linux to windows.
    What can I do?

    Thanks!!!
    vale


  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    So grub doesn't apear each time you booy up after the instalation?
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    16
    No Grub appears every time.
    If I select Ubuntu no problem.
    Instead if I select windows, the screen of windows appears and then the icons with login usernames appear. But If I click on the icon with my username all is freeze. If I click on "turn of" also it is also freeze.
    So I turn off the power and after the reboot and windows selection in grub and the automatic "scan disk" I can click on my username and normally go in windows.
    What appens?
    cheers
    vale

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Jan 2005
    Location
    Arizona
    Posts
    288
    Ok, so no matter what, if you turn off the power instead of rebooting, you can load Windows fine? Try passing acpi=off in your /boot/grub/menu.lst and see how your reboot to Windows goes.

    Are you mounting your C: partition in Ubuntu?
    Michael Salivar

    Man knows himself insofar as he knows the world, becoming aware of it only in himself, and of himself only within it.
    --Goethe

  6. #5
    Just Joined!
    Join Date
    Feb 2005
    Posts
    16
    sorry
    but in wich point of menu.lst must I write acp=off?

  7. #6
    Just Joined!
    Join Date
    Feb 2005
    Posts
    16
    About your 2 question:
    Maybe Yes
    I mounted Windows uder ubuntu too see my windows files from linux.

  8. #7
    Just Joined!
    Join Date
    Feb 2005
    Posts
    16
    I also noticed that if I select "shut down"
    from ubuntu, the machine restarts! Not good.

    thanks
    vale

  9. #8
    Linux User
    Join Date
    Jan 2005
    Location
    Arizona
    Posts
    288
    First, it's acpi=off, and it's in the kernel line of the Ubuntu section. It looks something like this:

    Code:
    # (1) Ubuntu Linux
    title  Ubuntu Linux
    root   (hd1,0)
    kernel /boot/vmlinuz-2.6.8.1-2-686 root=/dev/hdd1 acpi=off ro quiet splash
    initrd /boot/initrd.img-2.6.8.1-2-686
    Michael Salivar

    Man knows himself insofar as he knows the world, becoming aware of it only in himself, and of himself only within it.
    --Goethe

  10. #9
    Just Joined!
    Join Date
    Feb 2005
    Posts
    16
    ok
    I'll try and let you know.
    thans
    vale

  11. #10
    Just Joined!
    Join Date
    Feb 2005
    Posts
    16

    I added acpi=off where you told me. but nothing changes at windows boot and again if I select "shut down" from ubuntu it reboots.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •