Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I've been trying for what seems like ages now to install linux on my system. The biggest hurdle so far has been finding a distribution that will install/boot from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    11

    SuSE 8.0 not recognizing cd's 2-7 during install


    Hi, I've been trying for what seems like ages now to install linux on my system. The biggest hurdle so far has been finding a distribution that will install/boot from my medley raid. I've been able to install the first CD of suse 8, then after it is finished, yast needs to reboot to continue the installation. After rebooting, it asks me to insert disc 2, which is where KDE is located. The problem is, it won't recognize that there is a CD in the drive. It doesn't give me any insight as to what the error might be unless I ask for details, and they don't seem to help me much. The error is:

    "Could not mount the source medium. Mount: /dev/hdc is not a valid block device."

    Clicking on "ok" will make the error alternate between hdc and hdd, which I am fairly certain are my two CD drives. I've tried putting the disc in either drive, and it still does the same thing. I redownloaded the iso and verified the md5sum, and burned the CD at the slowest speed I could (8x). The same error came up.

    I got the bright idea then to try to install every single package to see if any of the other cds would work. After skipping CD2, the same error comes up for CD3, and so on. I've also verified the md5sum for the iso of disc 1, and reburned it at the slowest speed I could.

    I am able to skip CD2 and therefore not install KDE. My system then, naturally, boots to a command line interface which I could use to try to figure out what's going on here, if only I knew how to use it or even where to start.

    If anyone can offer some help or point me in the right direction, it'd be appreciated.

    Thanks.

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Perhaps the suse stock kernel cannot recognize your CD drive? this is only a guess, but try configuring it with yast from the command line:
    Code:
    yast2
    this should give you an ncurses-based menu selection to configure stuff. If that doesn't work, why don't you grab a copy of the newest kernel from http://www.kernel.org and recompile with support for your CD drive either hardcoded or as a module. These are all just blind suggestions, but post back with any questions/status updates
    Good Luck
    -lakerdonald

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    11
    Thanks for responding so quickly lakerdonald,

    I've been able to run yast from the command line, and I wasn't able to find anything about configuring my cdrom drives. I was, however, able to find under "hardware info" that it is detecting my drives correctly.

    I also did some further nosing about, and I am not able to access either cdrom drive through the command line, which shouldn't be a surprise. What is strange, is that I cannot access my floppy drive either. It IS entirely possible that I simply don't know how to properly access a drive.

    I also tried to install KDE through yast, but I got the same error when it needed to access my CDrom, even for disc 1.

    In other news, I was able to use yast to reconfigure Lilo to point it to the correct partition for booting my XP. That eliminated my next headache before it even began.

    As far as your second suggestion of recompiling a kernel with support for my cd drive...well...just how difficult is it to recompile a kernel? I'm about as new to linux as you can get.

    Thanks again.

  4. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Recompiling your kernel is really a breeze. Just I suggest you open up a Control Panel in Windows, and write down ALL of your hardware, this way you know what to enable in the kernel config. A good guide to compiling/installing the kernel can be found here:
    http://www.digitalhermit.com/linux/K...ild-HOWTO.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •