Find the answer to your Linux question:
Results 1 to 5 of 5
I am having problems playing a dvd with mplayer on Red Hat 9. When i use mplayer -dvd 1 (or any other number) i get an error saying that /dev/dvd ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Location
    Cyprus
    Posts
    96

    DVD Playback!


    I am having problems playing a dvd with mplayer on Red Hat 9. When i use mplayer -dvd 1 (or any other number) i get an error saying that /dev/dvd not found. I have a samsung 612s dvd rom that works fine in winxp. How can i get it to work with RH9? When i mount the dvd rom and try to play the .vob files with mplayer the mplayer starts but i only see a scramble signal.
    Any ideas???

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Try running the following as root.
    Code:
    ln -s hdc /dev/dvd

  3. #3
    Just Joined!
    Join Date
    Jun 2003
    Location
    Cyprus
    Posts
    96
    Cool it works great now thanks. I am beginning to like Linux more and more as days pass. I finally managed (with your precious help) to make it play mp3s, divx movies, dvds and log in the internet using my winmodem.
    Thanks again for your help i could not have done this without you,
    I am writting this message using my internet connection through Linux and Mozilla.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Even though that WinModem of yours works, you should consider getting a real modem instead. They use less system overhead, and are probably faster as well.

  6. #5
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    I have added this to my helpful tips page on my guide with screenshots and everything!

    look in the properties section of your mplayer and see "Misc" make sure your dvd device is to set to /dev/hdc for secondard master or to /dev/hdd if it is your secondary slave.

    also, you have to enable dma
    add this line to your /etc/modules.conf

    Code:
    options ide-cd dma=1
    also try gmplayer to open your dvd's instead of just mplayer in the term, ie:

    gmplayer -DVD 1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •