Find the answer to your Linux question:
Results 1 to 6 of 6
Install firefox from source ( post #1) I downloaded the tarbel ran tar zxvf firefox* ran the bin ./firefox-installer DOESNT INSTALL AND I GET THE FOLLOWING ERRORS (firefox-installer-bin:5999): Gtk-WARNING **: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    16

    installing firefox from source (please help)


    Install firefox from source ( post #1)

    I downloaded the tarbel
    ran tar zxvf firefox*
    ran the bin ./firefox-installer
    DOESNT INSTALL AND I GET THE FOLLOWING ERRORS

    (firefox-installer-bin:5999): Gtk-WARNING **: Unable to locate theme engine in module_path: "smooth",
    (firefox-installer-bin:5999): Gtk-WARNING **: Unable to locate theme engine in module_path: "smooth",
    (firefox-installer-bin:5999): Gtk-WARNING **: Unable to locate theme engine in module_path: "smooth",
    (firefox-installer-bin:5999): Gtk-WARNING **: Unable to locate theme engine in module_path: "smooth",
    (firefox-installer-bin:5999): Gtk-WARNING **: Unable to locate theme engine in module_path: "smooth",
    (firefox-installer-bin:5999): Gtk-WARNING **: Unable to locate theme engine in module_path: "smooth",
    [root@localhost firefox-installer]# /usr/lib64/firefox/firefox-installer/firefox-bin: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory

    im sure i have gtk cuz i saw it in a folder
    i tried locate libXp.so.6 found it was in /usr/X*/lib64, cp it to the firefox folder still same error.

    i first installed it to /usr/local/src/firefox...same error
    moved to /usr/lib64/firefox...same error
    am i installing it in the right place

    Please help me and thanks.

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    make sure that /usr/X11/lib64 is in your /etc/ld.so.conf, and then run ldconfig

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    16
    Yeah it is and i ran ldconfig
    i tried to reinstall but i still got the same error.
    this has to be the most simpllest installation in the world and i cant do it
    Please help and thanks

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2005
    Posts
    16
    could it be gtk+
    im sure i saw it in a folder somewhere
    installing gtk+2.0 looks like a pain...worse than firefox

    GOD PLEASE HELP ME

  6. #5
    Just Joined!
    Join Date
    Aug 2004
    Location
    UK
    Posts
    79
    SeptivaOra: Sorry, God is busy at the moment. Please tell us what distro you're using. I ask because it might be better if you tried installling what you need other than by starting with a tarball .

  7. #6
    Just Joined!
    Join Date
    Feb 2005
    Posts
    16
    im sorry
    fredora core 3
    amd64 3000+

    just a little frustrated...just got off school.

    i have looked at rpm's and the i386 rpm for firefox needslibray dependancies...where whould i put the library dependancies(/lib,/usr/lib)
    i can use yum but it uses the x86_64 bit version and many of the plugins are not supported for 64 bit.

    please help and thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •