when i ./configure terminatorX i recieve the following error

Code:
checking for liblrdf >= 0.2.4... Package lrdf was not found in the pkg-config search path.
Perhaps you should add the directory containing `lrdf.pc'
to the PKG_CONFIG_PATH environment variable
No package 'lrdf' found
./configure: line 8610: test: : integer expression expected
no
checking for scrollkeeper-config... /usr/bin/scrollkeeper-config
checking for X... no
checking for XOpenDisplay in -lX11... no
configure: error: ** X11-libs not installed or broken **
it wont create a make file cuz i cant use the make command. ive tried ./configure --x-libraries=/usr/X11R6/lib but had the same error. please help and thanks