Find the answer to your Linux question:
Results 1 to 8 of 8
I tried to install Mandrake Linux 10.1 atop a Windows XP pro PC. The whole installation process ran smoothly, until I restarted the computer after the setup was complete. It ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4

    hard drive missing


    I tried to install Mandrake Linux 10.1 atop a Windows XP pro PC. The whole installation process ran smoothly, until I restarted the computer after the setup was complete. It started printing out "L 99 99 99..." etc. etc. I found out it was because of a problem with the MBR, so I went into the Windows XP recovery console and typed the following:

    fixbook
    fixmbr

    That got me to boot into Windows XP fine, but now Windows won't detect one of the hard drives (the slave drive). I have two hard drives; an 80 gb one (the primary one; where Windows is installed), and a 200 gb one (the slave). The 200 gb hard drive has a 30 gb partition for Mandrake. Windows doesn't detect the entire 200 gb hard drive. Partition Magic reports some error and won't even open. Computer management in Windows XP's control panel says the entire hard drive is unallocated. Also I tried to run undelete w/ Partition Magic's rescue disks, but it doesn't even detect any partitions on the hard drive and won't recover anything.

    Normally, I would just reformat the entire drive and try reinstalling Linux, but I have a bunch of stuff on that hard drive. Any ideas?

    Thanks.

  2. #2
    Linux Newbie
    Join Date
    Jan 2005
    Posts
    157
    here are a couple of links:
    windows
    Linux
    The whole installation process ran smoothly, until I restarted the computer after the setup was complete.
    I assume here that you didn't say hit the reset switch on the PC or touch the power switch...
    You might give "System Commander" a try if you have access to it. Sounds like maybe the entire slave got formatted for Linux.

    Try a boot CD for Linux, like knoppix, and see if it can see the slave.
    If (exoskeleton || (green && wiggles)) eat_it();

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4
    Unfortuately, the data recovery tool didn't work. It won't even detect the hard drive to recover the files from. Someone told me that I could have messed up the partition tables (fixmbr warned me that it could), so I suspect that is the cause. Ideas on how to fix it?

    Thanks.

  4. #4
    Linux Newbie
    Join Date
    Jan 2005
    Posts
    157
    Someone told me that I could have messed up the partition tables
    try here and here
    result of google on: "data recovery damaged partition table"
    If (exoskeleton || (green && wiggles)) eat_it();

  5. #5
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4
    I tried about a dozen different solutions for it but none of them will restore my hard drive (although I managed to back up the most crucial files to my main hard drive). I'm trying to restore the partition tables because I don't want to reinstall Linux and risk doing this again and also because there's still a bunch of stuff on that drive that I can't backup because I don't have enough space. I tried active@ but the demo version only checks for problems, it doesn't fix them.

    Thanks for the help.
    - ysimonson

  6. #6
    Linux Newbie
    Join Date
    Jan 2005
    Posts
    157
    Download.com has proven pretty worthless to me. Usually any program you download that says free to try, $ to buy, will only do a teaser and then present you with the option of paying now for the full functionality (and here you have to trust that the software will work, and the ratings) or you can remove the software and further gunk up your registry. If you need to recover more data you will probably have to spend some $ on a piece of software that you have the most confidence in, maybe explain the damage to the companies sales rep first in an email and get some assurance that the software will perform as desired. If you are through trying to recover your data and are simply trying to reformat the disk and having trouble at this, you might try BCwipe which is free to try and fully functional demo but I think to restore a disk at a granular level it must be run from a separate hard drive and run from a command line prompt. The company is Jetico I believe. The documentation is included in the download.
    If (exoskeleton || (green && wiggles)) eat_it();

  7. #7
    Just Joined!
    Join Date
    Feb 2005
    Posts
    4
    OK thanks a lot for all the help . I guess i'll just reformat with just the files i've been able to backup. Any recommendations for a distro that won't kill my hard drive?

  8. #8
    Linux Newbie
    Join Date
    Oct 2004
    Location
    Arizona, USA
    Posts
    217
    FC3 or Ubuntu
    Linux is for those who want to know why their computer works.

    Registered Linux Machine #293111
    Registered Linux User #371115

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •