Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
Code: mount -t ntfs /dev/hdX /mnt/windows -o user,uid=500,gid=500 /dev/hdX = your device/partition, ie /dev/hda1 You unmount like this Code: umount /mnt/windows...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994

    Code:
    mount -t ntfs /dev/hdX /mnt/windows -o user,uid=500,gid=500
    /dev/hdX = your device/partition, ie /dev/hda1

    You unmount like this

    Code:
    umount /mnt/windows

  2. #12
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    Also NTFS is read-only when mounted on linux.

  3. #13
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    I should have phrased that better. I meant to say I want it to be readable by a regular user, not as root. I transferd all my files over from windows but I can only access them as root and that's no good...

  4. #14
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Quote Originally Posted by SiezedPropaganda
    Ok still having problems with Read Only permissions with Windows. I tried:
    Code:
    mount -t ntfs /mnt/windows user,uid=500,gid=500 0 0
    but it ends up giving me a list of mount options. Should I unmount and mount it again, if so how would I unmount it?
    That's all wrong. You have displayed some kind of weird combination between a mount command and a fstab entry. Try this instead:
    Code:
    mount -t ntfs /mnt/windows -o gid=500,umask=0227

  5. #15
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    Nope, I can still only read it as root...

  6. #16
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Can you do a "ls -l /mnt/windows"?
    And also, did you unmount before you remounted it?

  7. #17
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    Ah, I was doing the user ID wrong. My regular account is 501 not 500. They aren't writable but that isn't really an issue seeing as it's mostly pictures and videos. Thanks for all the help everyone, I don't know where I'd be without you...

  8. #18
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The fact that they aren't writable is very easy to explain: The Linux NTFS module doesn't support writing yet. I think they're working on it, but if you were to turn on write support now, you would most certainly crash the entire filesystem.

  9. #19
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    Yeah I read something about that after I posted. Good to hear they're working on something...

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •