Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
Hi everybody anyone could give me an advice on how to solve this problem? I have Red Hat 7.2 I only have a LG CD-RW CED-8080B When i click on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2003
    Location
    Spain
    Posts
    8

    cannot mount my cdrom


    Hi everybody
    anyone could give me an advice on how to solve this problem?

    I have Red Hat 7.2
    I only have a LG CD-RW CED-8080B
    When i click on the CD-ROM icon or try to mount it, I become the
    following message:
    "The device could not be mounted
    mount: /dev/cdrom: unknown device"

    I'm a novice in linux, but an expert tried to help me and couldn't solve the problem.
    Waiting for your help. Best regards.

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Do you have the /dev/cdrom file? If you don't, run these commands:
    Code:
    su -
    (Enter your root password)
    ln -s hdc /dev/cdrom

  3. #3
    Just Joined!
    Join Date
    Jul 2003
    Location
    Spain
    Posts
    8

    the file exists

    thanks.
    well, yes, it seem so, 'cause the answer was:

    ln: '/dev/cdrom': the file exists

    and now, should i send you the file?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Certainly not. It's supposed to be the CD-ROM drive. Instead, check what these commands return:
    Code:
    ls -l /dev/cdrom
    ls -lH /dev/cdrom
    cat /etc/fstab
    I must also say that "unknown device" seems like a strange error message. It's not a system standard one. Did you translate it from another language? Otherwise, could you check so that it is precisely that it says, and if it really is, please insert a CD into the drive and run "mount /dev/cdrom" and see what it says.

  6. #5
    Just Joined!
    Join Date
    Jul 2003
    Location
    Spain
    Posts
    8

    answers

    Yes and no :-O The error message is partially in another language (spanish), but not this 2 words; the complete and original message is:

    No se pudo montar el dispositivo.
    El mensaje de error fue:
    mount: /dev/cdrom: unknown device

    I guess you should also know that it's not a hardware problem, since i have on that computer Windows too, and in Windows i can use the cdrw perfectly.

    your commands:

    ls -l /dev/cdrom
    returns
    lrwxrwxrwx 1 root root 9 jun 17 14:34 /dev/cdrom -> /dev/scd0

    ls -lH /dev/cdrom
    returns
    ls: Warning: the meaning of '-H' will change in the future to conform to POSIX.
    Use '--si' for the old meaning.
    lrwxrwxrwx 1 root root 9 jun 17 14:34 /dev/cdrom -> /dev/scd0

    cat /etc/fstab
    returns
    LABEL=/ / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /proc proc defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    /dev/hdc3 swap swap defaults 0 0
    /dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

    mount /dev/cdrom
    returns
    mount: /dev/cdrom: unknown device

    what do you think?

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It would seem that your SCSI emulation isn't turned on properly. What physical device is your CD-ROM (ie. what place on which IDE bus does it have)?

    I deleted the first of your duplicate posts. You didn't mind, did you?

  8. #7
    Just Joined!
    Join Date
    Jul 2003
    Location
    Spain
    Posts
    8

    cdrw is my secondary device in the primary bus

    no, i don't mind it at all; excuse me, i didn't want to send it twice ... and after i didn't know how to remove it

    well, as i said, i'm a novice at linux but ... i don't understand why do i need SCSI emulation , since i don't have a scsi driver, but just IDE ones.

    - I have a Hard Disk of 20 Gb (with Windows installed) as the master device
    in the primary bus.
    - I have a 2nd Hard Disk of 6 Gb (with Red Hat installed) as the master
    device in the secondary bus.
    - And I have the CDRW as the secondary device in the primary bus

    Best,

  9. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The reason you need SCSI emulation is because it is a CD burner. Don't get me wrong, Linux fully supports IDE burners and all, but there are no actual programs to burn to IDE burners. They all use the SCSI interface. Why there hasn't come any IDE burner programs for Linux, I don't know.

    Anyway, check what the following commands return.
    Code:
    cat /proc/ide/hdb/driver
    /sbin/lsmod
    cat /proc/cmdline
    cat /etc/modules.conf
    hdb is the designation for the primary slave in Linux.
    The last command needs to be run as root.

    I didn't want to make you feel bad about posting twice, I just wanted to check so that everything was as I though.

  10. #9
    Just Joined!
    Join Date
    Jul 2003
    Location
    Spain
    Posts
    8

    the commands' answers

    ok, thanks for the explanation about scsi.
    anyway, don't care, i don't want to burn cds with linux, just want to read them.

    the commands:

    cat /proc/ide/hdb/driver
    returns
    ide-scsi version 0.9

    /sbin/lsmod
    returns
    Module Size Used by
    es1370 27232 1 (autoclean)
    gamesport 1840 0 (autoclean) [es1370]
    soundcore 4208 4 (autoclean) [es1370]
    binfmt_misc 6064 1
    autofs 11232 0 (autoclean) (unused)
    8139too 12640 0
    ide-scsi 7872 0
    scsi_mod 92208 1 (ide-scsi)
    ext3 61936 2
    jbd 38976 2 [ext3]

    cat /proc/cmdline
    returns
    ro root=/dev/hdc2 hdb=ide-scsi

    cat /etc/modules.conf
    returns
    alias parport_lowlevel parport_pc
    alias eth0 8139too
    alias sound-slot-0 es1370
    post-install sound-slot-0 /bin/aumix-minimal - f /etc/.aumixrc -L >/dev/null 2>&1 || :
    pre-remove sound-slot-0 /bin/aumix-minimal - f /etc/.aumixrc -S >/dev/null 2>&1 || :
    alias char-major-81 bttv
    You have new mail in /var/spool/mail/root

  11. #10
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Add these lines to your /etc/modules.conf, then reboot:
    Code:
    options ide-cd ignore=hdb
    alias block-major-11 sr_mod
    add above sr_mod ide-scsi
    (And yes, there are ways to avoid a reboot - this is Linux, after all - but it's the easiest way for me to explain)

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •