Find the answer to your Linux question:
Results 1 to 6 of 6
I am currently trying to install debian GNU/Linux. I got a minimal CD to install from. I installed on my D: and kept Windows 98 on C: I confidured lilo ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2003
    Posts
    4

    About to give up. Installed but only can run terminal


    I am currently trying to install debian GNU/Linux. I got a minimal CD to install from. I installed on my D: and kept Windows 98 on C: I confidured lilo to boot from the small partition on D: But when I boot it always goes to c: and starts windows. If I change the boot order in BIOS to boot D: first, I get to the part where linux boots and my screen fills up with 10 10 10 10 10 ... I have to boot each time from the floppy I made during install. Not all bad, if I want linux instead of Windows, I just push the disk in before power up. It boots fine. I partitioned and mounted the drive meticulously with 8 partitions including swap and a small bootabe partition (8MB) at the beginning of D: (separate from the root). Why won't it boot from d: correctly? And I have a network connection that works, I can only browse the web with lynx. X won't start because it can't find a screen resolution that works. I have a STB Velocity NVidia 128 AGP and 17" Proview monitor. I have tried VGA VESA and nv with different color (8,16,24 bit) and resolutions (600x800, 1024x72. Nothing works. Maybe its the monitor? I downloaded the nvidia linux installer and it won't work because it can't find my linux kernel type. Maybe cause I boot from floppy? The kernel header files are not installed as far as I can tell. When I type uname -r it says 2.2.20-idepci Can anyone help with boot or video?

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    How did you install LILO? It sounds to me as if you didn't install it on the MBR. Do you get a LILO screen at all before Windows boots?

    2.2.20 is an eon old (it's dated Nov 2 2001). What version of Debian is this?
    I guess it is possible that your monitor settings are wrong, but I think it should still be able to go at 640x480. What version of XFree86 do you have, and what does your Monitor section look like?

  3. #3
    Just Joined!
    Join Date
    Jul 2003
    Posts
    4
    Lilo installed as part of the initial text-based installation. First it asked me to partition the drive, then how to mount each drive (/home /root /bin etc.) and asked me which partition for a swap. It then set up the network (DHCP) which is served by a windows 98 machine with DSL. This all worked well. Then it said setting up Lilo. It said it found another bootable operating system and asked if I wanted Lilo to set it up in a menu so I could choose which to boot (linux or win9. The first time through installatiion I answered yes to have the other operating system as a bootable option. Then it asked where I wanted to write the MBR. It gave me the choice to over-write the existing or write one to the small partition on the D: drive that I set up as the 8MB "bootable partition" with the linux partition program. I chose to overwrite the current one. I assume Win98 had already set up the MBR and Linux Lilo wrote over it. It then created a floppy bootable disk and said the system was ready to boot Linux. Remove all disks and restart. Windows then booted. I disabled the c: in BIOS and tried again but this time I got "10 10 10 10 10 10 10 repeating until the system locked up. So I started all over. This time when install asked if Lilo should keep the other bootable OS I said yes, but elected to write the MBR to the small 8MB partition on D: . Same result. So each time I boot, I must insert the bootable floppy and it loads linux kernel from there. The kernel version on that disk is the one you ask about. I have edited the XF86Config-4 file and changed some of the display settings manually but no success. I also ran dexconf a couple times aech time selected different drivers and resolutions and refresh rates. One warning message was given when installation set up Lolo. It said something like "warning you are setting to boot from d: (slave drive) which may not be supported my some Bios." I said "continue". The computer is a Dell P233 with original hardware.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    May 2003
    Location
    Hong Kong, China
    Posts
    256
    i came across this problem as well. hm
    Signature removed by moderator - please see forum rules

  6. #5
    Linux Newbie
    Join Date
    Apr 2003
    Location
    UK, Manchester
    Posts
    147
    Install lilo to the mbr of your C drive. In the bios tell it to boot from the C drive.
    When you install lilo make sure it has added an entry for windows.Otherwise there wont be a way of getting into windows.

    By default debian uses the 2.2.x kernel but you can (and should) select the 2.4x kernel during install. When you first start the install press F3 and check the options you have. You should choose bf2.4.

    You should hae a read through the install manual.

  7. #6
    Just Joined!
    Join Date
    Jul 2003
    Posts
    9
    try running xf86config. make shure you know all the specs of your monitor and card.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •