Find the answer to your Linux question:
Results 1 to 10 of 10
I recently got the SUSE 9.2, and here's what happened when i tried to install it: - both CD and DVD boot correctly - then "Loading Linux Kernel" - when ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8

    problem install suse 9.2


    I recently got the SUSE 9.2, and here's what happened when i tried to install it:

    - both CD and DVD boot correctly
    - then "Loading Linux Kernel"
    - when Kernel finishes loading(actually shows 99%, so maybe doesn't finish), the screen goes black, and nothing else happens.

    Alternative methods I have tried but didn't work:
    - set bios to PATA, but didn't change anything.
    - tried remove the 2 SATA and install only with presence of PATA, and pre-partitioned on PATA
    - tried install alternative linux: Suse 9.0(boot from floppy showed reading error) , RedHat7.2(similar problem to Suse 9.2)

    Apparently the pb doesn't come from the SATA hard drives. How can I install it? I'm nearing desperation...

  2. #2
    Linux User
    Join Date
    Jan 2005
    Location
    Arizona
    Posts
    288
    Could you please list your full system specs to the best of your ability. It sounds like you're familiar with the hardware, but if not and you can boot to a live cd, then an lspci and lsmod may help. Are you booting the installer with any special parameters?

    Have you tried any non-Suse distributions? Maybe one of their install kernel patches just doesn't like your system.
    Michael Salivar

    Man knows himself insofar as he knows the world, becoming aware of it only in himself, and of himself only within it.
    --Goethe

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8
    Here's My config :
    -P4 northwood 2.8
    - Asus P4P800
    - ATI radeon 9000
    - 2GB Corsair xms
    - 1xATA133 Maxtor 120GB,8mb
    - 2xSATA WDC raptor 36GB 10k/m
    - DVD reader,DVD burner, SB audigy2,etc

  4. #4
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8
    Quote Originally Posted by Ethyriel
    Could you please list your full system specs to the best of your ability. It sounds like you're familiar with the hardware, but if not and you can boot to a live cd, then an lspci and lsmod may help. Are you booting the installer with any special parameters?

    Have you tried any non-Suse distributions? Maybe one of their install kernel patches just doesn't like your system.
    I have tried with Redhat7.2 and similar thing happened.
    i tried booting the installer using all the listed possibilities including "manual install".
    How do I boot with lspci & lsmod? "lspci=on & lsmod=on" ?

  5. #5
    Linux User
    Join Date
    Jan 2005
    Location
    Arizona
    Posts
    288
    Sorry, I wasn't clear on that. Those are commands, lspci and lsmod, one listing devices on the PCI bus, the other listing modules which are loaded. I was suggesting them if you weren't sure what hardware was in your machine.

    It sounds like maybe your video modes aren't getting automatically set properly. What kind of monitor and video card do you have? It's quite possible that the frequencies are getting set out of the monitor's range and so it's going black when the xserver starts up. If these distributions allow you to, you could try setting them from the boot manager, or you could try booting into a text installer, I'm pretty sure Suse offers that option from the boot manager.

    Let me know how this goes.

    Oh, and let it sit for awhile (15 minutes, maybe). I've seen kernel settings and hardware conflicting with certain xorg.conf settings make X take forever to start up. It usually runs like an absolute dog after this, but at least it would give us a clue.
    Michael Salivar

    Man knows himself insofar as he knows the world, becoming aware of it only in himself, and of himself only within it.
    --Goethe

  6. #6
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8
    I tried to install using text mode, and the system idles after "ACPI: IRQ9 SCI: Edge Set To Level Trigger".

    Doesn't mean a lot to me...

  7. #7
    Linux User
    Join Date
    Jan 2005
    Location
    Arizona
    Posts
    288
    Ok, so try turning ACPI off with a boot parameter. I think the latest Suse offers this option from a menu, if I remember correctly. You're looking for 'acpi=off', and if that doesn't do it, you could try 'acpi=force', I suppose. Keep in mind, just because you have to use this boot parameter when you're installing (if it even works), doesn't necessarily mean you'll need it for normal booting. There are different kernels in use.
    Michael Salivar

    Man knows himself insofar as he knows the world, becoming aware of it only in himself, and of himself only within it.
    --Goethe

  8. #8
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8
    I tried both "acpi=off" then "acpi=force" but the same result happened...
    I found this page : http://www.ussg.iu.edu/hypermail/lin...09.3/0624.html

    it has to do with a patch (My kernel is 2.6.8 )... I suppose I have to compile the vanilla version.
    But how do I compile the vanilla version without having any linux installed yet?

  9. #9
    Just Joined!
    Join Date
    Mar 2005
    Posts
    8
    The problem has been solved.
    I had a USB hub plugged, which caused the installer to crash everytime.
    Thanks for the advice anyway

  10. #10
    Linux User
    Join Date
    Jan 2005
    Location
    Arizona
    Posts
    288
    It's just good to see you got it fixed.
    Michael Salivar

    Man knows himself insofar as he knows the world, becoming aware of it only in himself, and of himself only within it.
    --Goethe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •