Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 30
well, like I said, they worked they way they should in terms of ejecting... eject /dev/scd0 = ejected dvd rom (sec master) eject /dev/scd1 = ejected cd writer (sec slave) ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556

    well, like I said, they worked they way they should in terms of ejecting...

    eject /dev/scd0 = ejected dvd rom (sec master)
    eject /dev/scd1 = ejected cd writer (sec slave)

    it's good to know that I don't need to change my fstab, here are lines I currently have regarding the roms:

    Code:
    /dev/cdrom             /mnt/cdrom             udf,iso9660 noauto,owner,kudzu,ro 0 0
    /dev/cdrom1            /mnt/cdrom1            udf,iso9660 noauto,owner,kudzu,ro 0 0

    maybe there is something in there that is messing this up?

    basically I am just backtracking to see what is going on. I thought I had things configured correctly, but I guess it is just better to review the entire setup

  2. #12
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Well, if /dev/scd0 is your DVD, and /dev/cdrom points to /dev/scd0, how then can the DVD-ROM get mounted on /mnt/cdrom1 if your fstab entry binds /dev/cdrom to /mnt/cdrom? Have you really doublechecked your symlinks? I guess you can always try to temporarily change your fstab to bind /dev/scd0 to /mnt/cdrom and /dev/scd1 to /mnt/cdrom1, to see if that does anything good.

  3. #13
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    I didn't say I wanted my dvd rom to mount on cdrom1, but that is where it seemed it was accessible at the time.

    What is the best way to get rid of those symlinks? Just delete them thru gui? unlink them somehow, I think I will start over on them just to be sure.

    I find that kind of odd though, because when I look in my /mnt/cdrom and /mnt/cdrom1 directories, I can see the symlink symbols and they are pointing to the right devices.

    Also, the only way I can create the symlinks is by getting root privs.


    UPDATE: I logged on as root and notice that it also had my drives backwards when I ran k3bsetup.

    It had /dev/cdrom1 as my dvd rom which is wrong
    and my burner as /dev/cdrom.

    It won't allow me to change it either, I can change where they mount in it, but I can't change the device it seems.

  4. #14
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Quote Originally Posted by yowwww
    I didn't say I wanted my dvd rom to mount on cdrom1, but that is where it seemed it was accessible at the time.
    Yes, that was what I meant. I was just wondering how it could be possible.

    Quote Originally Posted by yowwww
    What is the best way to get rid of those symlinks? Just delete them thru gui? unlink them somehow, I think I will start over on them just to be sure.
    "rm /dev/cdrom*"?

    Quote Originally Posted by yowwww
    Also, the only way I can create the symlinks is by getting root privs.
    Well naturally - how else were you planning on writing to /dev?


    Quote Originally Posted by yowwww
    UPDATE: I logged on as root and notice that it also had my drives backwards when I ran k3bsetup.

    It had /dev/cdrom1 as my dvd rom which is wrong
    and my burner as /dev/cdrom.

    It won't allow me to change it either, I can change where they mount in it, but I can't change the device it seems.
    Well, just delete the symlinks and recreate them correctly, then.

  5. #15
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    ok, making some progress here:

    Code:
    [root@localhost ctm]# rm /dev/cdrom
    rm: remove symbolic link `/dev/cdrom'? y
    [root@localhost ctm]# rm /dev/cdrom1
    rm: remove symbolic link `/dev/cdrom1'? y
    [root@localhost ctm]# ln -s /dev/scd0 /dev/cdrom
    [root@localhost ctm]# ln -s /dev/scd1 /dev/cdrom1

    my dvd rom now works perfectly fine and appears to mount at /mnt/cdrom, but not cd writer keeps saying this:

    Code:
    Could not mount device.
    The reported error was:
    mount: wrong fs type, bad option, bad superblock on /dev/cdrom1,
    or too many mounted file systems
    I am using the exact same cd that worked on the dvd rom (linux install cd)

    I even logged in as root to make sure things looked right in k3b and everything seems fine. I checked in user mode and it looks fine also.

    I have left my relevant cd rom fstab entries in tact

    Code:
    /dev/cdrom              /mnt/cdrom              udf,iso9660 noauto,owner,kudzu,ro 0 0
    /dev/cdrom1             /mnt/cdrom1             udf,iso9660 noauto,owner,kudzu,ro 0 0

  6. #16
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What happens if you, with the CD in the writer, run "file -s /dev/scd1"?

  7. #17
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    I get this:

    Code:
    file -s /dev/scd1
    /dev/scd1: data
    also tried this:

    Code:
    mount /dev/scd1 /mnt/cdrom1
    and got his result:
    Code:
    /dev/scd1: Input/output error
    mount: block device /dev/scd1 is write-protected, mounting read-only
    mount: /dev/scd1 already mounted or /mnt/cdrom1 busy
    so then I try this:

    Code:
    umount /dev/scd1
    and I get this response:

    Code:
    umount: /dev/scd1: not mounted
    I checked my /mnt/cdrom1 directory and it didn't show any files. I get the same result no matter where I direct it to mount. It appears there is a problem with the permissions or something with /dev/scd1. I checked the permissions for /dev/scd0 and /dev/scd1 and they are the same in /dev.

  8. #18
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What happens if you do "cat /dev/scd1 >/dev/null"?
    Also, check "cat /proc/ide/hdd/driver".

  9. #19
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    with no cd in:

    Code:
    cat /dev/scd1 >/dev/null
    cat: /dev/scd1: No medium found
    with a cd in:

    Code:
    cat /dev/scd1 >/dev/null
    cat: /dev/scd1: Input/output error
    Code:
    cat /proc/ide/hdd/driver
    ide-scsi version 0.93

  10. #20
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    What the...? I've never had ide-scsi devices return EIO. Do you get any kernel messages?

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •