Find the answer to your Linux question:
Results 1 to 7 of 7
Mayday Mayday!!!! Permission denied while trying to edit /etc/fstab tried # su tried remounting every single mount points still no luck How on earth an I sopposed to do???? Damn ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    May 2003
    Location
    Hong Kong, China
    Posts
    256

    Gentoo installation well stuck in the middle, urgent!!!


    Mayday Mayday!!!!

    Permission denied while trying to edit /etc/fstab
    tried # su
    tried remounting every single mount points
    still no luck

    How on earth an I sopposed to do???? Damn it, so dumb, my pc is still on, AMD system is an oven(overclocking makes it like cooking) is it possible turn it off and go back to where I was when I want to?

    PS: I skipped swap activation and time zone settings, not a big mistake, right???? ho ho ho................... sigh




    Installation code 17 Modifying /etc/fstab for your machine

    Your Gentoo Linux system is almost ready for use. All we need to do now is configure a few important system files and install the boot loader. The first file we need to configure is /etc/fstab. Remember that you should use the notail option for your boot partition if you chose to create a ReiserFS filesystem on it. Remember to specify ext2, ext3 or reiserfs filesystem types as appropriate.

    Use something like the /etc/fstab listed below, but of course be sure to replace "BOOT", "ROOT" and "SWAP" with the actual block devices you are using (such as hda1, etc.)

    Code listing 17.1: Editing fstab

    # /etc/fstab: static file system information.
    #
    # noatime turns off atimes for increased performance (atimes normally aren't
    # needed; notail increases performance of ReiserFS (at the expense of storage
    # efficiency). It is safe to drop the noatime options if you want and to
    # switch between notail and tail freely.

    # <fs> <mount point> <type> <opts> <dump/pass>

    # NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.

    /dev/BOOT /boot ext2 noauto,noatime 1 2
    /dev/ROOT / ext3 noatime 0 1
    /dev/SWAP none swap sw 0 0
    /dev/cdroms/cdrom0 /mnt/cdrom iso9660 noauto,ro 0 0
    proc /proc proc defaults 0 0

    Warning: Please notice that /boot is NOT mounted at boot time. This is to protect the data in /boot from corruption. If you need to access /boot, please mount it!
    Signature removed by moderator - please see forum rules

  2. #2
    Linux User
    Join Date
    May 2003
    Location
    Hong Kong, China
    Posts
    256
    someone told me I have to type the command nano -w /etc/fstab instead.

    going to try it tonight.
    Signature removed by moderator - please see forum rules

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    You didn't accidently mount the root filesystem as read-only or anything, did you? Of course, that shouldn't make it reply permission denied, but stranger things have happened.
    I assume that you get permission denied when you actually try to save the file, right?

  4. #4
    Linux User
    Join Date
    May 2003
    Location
    Hong Kong, China
    Posts
    256
    eh, fstab problem solved
    now is the network!
    i think i'd better give up on gentoo, ha ha ha
    hm, need to do more learning
    Signature removed by moderator - please see forum rules

  5. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Why give up? Trial is the best way to learn, isn't it?

  6. #6
    Linux User
    Join Date
    May 2003
    Location
    Hong Kong, China
    Posts
    256
    he he, pessimistic, right? hm, well, As I said before, Gentoo Linux is not right for me since it takes too much time both installing and configure, and I am still not capable of Building a Linux system. I just tempted tried it out, I failed to install it for the first time, so I tried the second time, got it installed, able to boot into my system, but eth0 is down, various problems existed, so I leave it there, I always have a spare small HD(10G) for testing out, no harm at all.
    Signature removed by moderator - please see forum rules

  7. #7
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    Setting up the network is actually quite easy to do especially if you use dhcp. Just run dhcpcd eth0 and you are finished.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •