Find the answer to your Linux question:
Results 1 to 4 of 4
I'm not sure if this is an installation, configuration, or hardware issue, so I'll start here... I installed Fedora Core 3.0 on an old Compaq Deskpro - PII 266 256M. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    5

    FC3 installation won't boot


    I'm not sure if this is an installation, configuration, or hardware issue, so I'll start here...

    I installed Fedora Core 3.0 on an old Compaq Deskpro - PII 266 256M. I thought I might have some issues when the graphical FC installer wouldn't work (also a Red hat 7.3 graphical AND text installer kept crashing). Finally, the text FC3 worked, despite a few interruptions complaining about not being able to read the CD, which were fixed by retrying.

    Now, when it boots, all looks good (no 'FAILS') until it complains about the BIOS date fails cutoff and ACPI will be forced - don't know if this is a show-stopper or not. Then it displays 'Configuring Kernal Parameters' where it hangs for a while ( I ran out of patience after 20 minutes). Pressing Ctrl-c kickstarts it - it changes to run-level 5 and complains about RO files systems and can't open this or that until I've had enough and reboot it.

    I know the details are sketchy, but I don't even know where to look for a low-level "safe-mode" or interactive boot to see what fails where. I can't boot far enough into Linux to use its diagnostic abilites. So now what?

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Can you post the exact error you get please?
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    5
    After re-installing it, a few things have changed. First of all, the graphical installer worked this time and there were fewer disk-read errors. I'm not blaming them on Linux because the Cd-ROM is from 1998.

    There's the ACPI message about the BIOS failing the date check and forcing ACPI - like I said, I don't know if this matters or not.

    Next the system hangs on "Configuring kernal parameters" - nothing happens (for at least 20 minutes). If I press ctl-c then I get

    touch: cannot touch /var/lock/subsys/kudzu: read-only file system
    touch: cannot touch /var/lock/subsys/iptables: read-only file system
    touch: cannot touch /var/lock/subsys/kudzu: read-only file system

    I seem to have a read-only file system even if I try to change the start-up options to rw.

    Some combination of cussing, pounding on keys, and rebooting did get me once into a bash shell. I looged in as root and poked around but was still locked in a read-only mode of some sort. It wasn't the rescue mode because it would let me log all the way out to the login screen without rebooting

  4. #4
    Just Joined!
    Join Date
    Mar 2005
    Posts
    5

    Resolution (for those who care...)

    It was a combination of a bad CD-ROM drive which wouldn't let me boot from and install from the 7.3 cd's, and some screwed-up driver in FC3. Right now 7.3 is running happily - I'll try an upgrade to FC3 and see if it loads and boots this time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •