Find the answer to your Linux question:
Results 1 to 3 of 3
System(s) Used: 1. P4 1.8 Ghz - Promise Fasttrak 100 TX 2 RAID 1 – 2 x 40GB - 1GB DDR to be used as a webserver. 2. AMD 900 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2003
    Posts
    2

    RH7.2, RH7.3 and SUSE 8.1 Hardware Problem


    System(s) Used:

    1. P4 1.8 Ghz - Promise Fasttrak 100 TX 2 RAID 1 – 2 x 40GB - 1GB DDR to be used as a webserver.
    2. AMD 900 Mhz, 1 x 40GB, 2 x Removable HD Drives (for cloning), 256 MB RAM, used as a personal system

    Level of knowledge

    I am new to linux and an reasonably experienced Win 2K Server user.

    Problem Description

    1. Installed Suse 8.1 on System 1. Suse recognised the Raid controller immediately and installed perfectly. However since i needed Coldfusion MX on this system, i needed to convert to Red Hat 7.3 which is the latest distribution to be supported by Coldfusion MX. (so i thought, later i would find out that it’s actually RH7.2)
    2. Converted to Red Hat 7.3 with driver downloaded from promise.com for support of the Raid Controller.
    3. Some errormessages popped up. I booted out of the installation which may have caused all the problems; After this Red Hat 7.3 wouldn’t install anymore and guess what, neither did Suse 8.1 nor RH7.2.
    4. Tried to install Windows 2000 server, no problem, worked at once
    5. Used Fdisk/mbr, ranish and eafdisk /restore:file.mbr and tried to install RH7.2, no results
    6. Tried Lilo in RH7.2, tried to install on first sector i.s.o. in mbr, no results
    7. Flashed the bios, no results
    8. Tried to low-level format the Harddisks but the software from Maxtor does’t appear to recognise the partition tables, so this didn’t work.
    9. Installed RH7.2 on system 2, cloned it to the two disks on the RAID controller of system 1, didn’t work.
    10. Stripped the RAID controller and used the Harddisk from system 2 in system 1, installed RH7.2, this worked however after startup the system started up in none-graphical mode without USB support.
    11. Put the Harddisk from system 2 that for the time was in system 1 back into system 2, installed again and RH7.2 was fully functioning again.

    Errors that occured (on system 1)

    1. RH7.2: Kernel Panic, error during making of boot floppy (have to skip), hanging during ‘installing bootloader’, USB error, error reading partition table, invalid partition table
    2. Suse8.1: kernel panic, invalid partition table, or system seemed to install correctly but after install showed a red screen with bombs and became so slow that it became impossible to alter settings. After reboot Suse then hangs.

    Questions

    1. Where can the source of my problem be located ? Somewhere must be a piece of information that Linux is remembering in spite of all the formatting, fdisk in linux/ dos etc. etc. Something has permanently changed in system 1 because Suse doesn’t want to reinstall and this was working properly before. Can it be in the MBR of the Harddisks of system 1 ? If not there , where else can information be stored ? What do i have to do to get the graphical version of Linux installed on system 1 ?
    2. After a boot In text version in RH7.2, what do i have to do to start up the GUI KDE ?
    3. Why is my USB not recognised anymore by RH7.2 ?
    4. What does the errormessage Kernel Panic mean ?
    5. Can a MBR be corrupted for only one computersystem and be still good performing in other systems ?

    Please Help, Dirk-Jan de Groot – The Netherlands

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2002
    Location
    San Antonio
    Posts
    621
    1: it is somewhere in the hardware raid card maybe? I know certain sound cards sometimes need to be booted into DOS/Windows at least once to "set them up" correctly.
    2: try `telinit 5` and edit /etc/inittab to change the initdefault to 5, from 3
    3: maybe cause 7.2 is about 2 years old.
    4: kernel panic is just a general error. It says something happened in the kernel, and it tries to give you more information. The information was probably something like "failed to mount root device (13:0" or something like that. That means that it failed to find the right hard drive to boot up with.
    5: MBR is on the HDD, so if the HDD is put in one computer system, it should work in any computer system. MBR is just defined as the first 512 bits of information on the hard disk that tells the computer what to do from there.
    I respectfully decline the invitation to join your delusion.

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Install RedHat in text mode, and when the errors occur, switch to tty3 or tty4 (by pressing ALT+F3 or ALT+F4, resp.) to see what's logged. If the kernel panics the complete error message would show up directly on the screen if you're in text mode.

    Kernel panic means that your kernel (you do know what the kernel is, right?) has encountered a condition from which it cannot recover, such as a kernel bug, which is very rare unless you're using a buggy driver, which are usually pretty rare, too. It can also be what wassy describes, such as the inability to mount the root fs or that it can't find init or so. Those things mainly happen on boot-up, though, when there's only one task running.

    You need to tell us more precisely where in the process things go wrong, and more precisely how they go wrong. It's not sufficient with 'no results', since there are always _some_ results.
    USB _is_ recognized by 7.2. USB is far older than two years, and it is supported in 7.1.

    I don't know if you really know what the MBR is? It stands for Master Boot Record, and is the first sector (1 sector = 512 bytes) of each hard drive. Some BIOSes only use the first hard drive for booting, though, but each hard drive has a MBR. It contains both the boot code, like LILO or GRUB, and the primary partition table for each hard drive.

    I know 7.2 has GRUB. You should use that instead of LILO.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •