Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11

    Quote Originally Posted by prosen
    I thought about the / and /boot being same too !!! anyway .. I am not sure,
    but I am missing the initrd line in your grub.conf. I am not sure about
    gentoo, does it not use any initrd image ???
    If it uses initrd, then I guess you may have to specify the initrd image file.
    It should be relative to /boot as well, ie., just append /boot in front of the
    initrd image file name.
    I have it there cos i have personally added an initrd so u have framebuffer splash screens on boot
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  2. #12
    Linux Newbie
    Join Date
    Jul 2004
    Calcutta, India
    Just as an effort , have you tried this ??
    grub-install --root-directory=/boot /dev/hdb1
    you may also have to check upon the file .

    Check this link :

    Hope it helps you man .., I really do feel your pain .. I got some of it last year myself.

  3. #13
    Linux Guru
    Join Date
    May 2004
    Quote Originally Posted by prosen
    I really do feel your pain ..
    No kidding: it's agonizing watching so many people having such a hard time with Grub. One fix that should definitely be considered, cgkanchi, especially since you are the only one who uses Linux, is to create a Grub boot floppy. If you can boot into your Linux, it's a simple matter of putting in a good floppy and then:
    # grub
    grub> root (hd1,0)
    grub> setup (fd0)
    grub> quit
    Then, when you want to boot, put in your boot floppy, boot to it and you'll get the Grub menu on your hard drive. Please check the commands by running 'info grub' because I'm not at my Linux machine to check my memory, but the procedure is very similar to what I wrote. It's nearly painless.
    //got nothin'
    ///this use to look better

  4. $spacer_open
  5. #14
    OK, I am sick and tired of this. I think I'll just download lilo and go ahead with it, since I'm waaay more comfortable with lilo.

    For the record, I did try the --root-directory=/boot. It didn't work. The other option, a boot floppy isn't an option for me since I don't have a floppy drive .


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts