Find the answer to your Linux question:
Results 1 to 7 of 7
I have a multi-boot with Fedora Core 2, Suse 9.2, and Windows XP. Whenever I try to boot with my keyboard plugged into the USB port, I can't select which ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    3

    Boot loader problems... USB keyboard doesn't work


    I have a multi-boot with Fedora Core 2, Suse 9.2, and Windows XP. Whenever I try to boot with my keyboard plugged into the USB port, I can't select which system I would like to boot from in the boot loader. Neither LILO nor GRUB work (using USB). However, I can use both boot loaders with the PS/2 port... but windows becomes tempermental and doesn't recognize a keyboard in the PS/2 port. To summarize...

    -----USB-----
    BIOS - yes
    GRUB - NO
    LILO - NO
    Windows - yes
    Linux - yes

    -----PS/2-----
    BIOS - yes
    GRUB - yes
    LILO - yes
    Windows - NO
    Linux - yes

    I have done a fair amount of research, it seems a common issue is that the BIOS setting for USB keyboard support is not set. I don't see any setting like that in my BIOS... but I don't think it matters anyway since my keyboard does work in the BIOS and all my operatings systems.

    I have a suspicion it's my motherboard -- Jetway A350DMS. It was a mistake to get... I am hoping to replace it in the near future. I would like to use my USB KVM switch -- so this is starting to become very irratating. Any thoughts are greatly appreciated. I just don't know where to start.

    Jason

  2. #2
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    The only thing I can suggest, but I thik you have covered it, is to check that you have USB Legacy Support enabled in the BIOS, but I think you have covered this already
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    3

    resolved---- somewhat

    I looked in the manual for the Legacy USB support option apparently it exists. So I went into the BIOS setup again to look for it. I got to the menu screen that was shown in the user manual--- except there was not option in my BIOS. Called Jetway and the guy immediately confirmed that my mother board (A350 DMS) had a bug with the legacy support so they just removed the option.

    Moral of the story... don't buy Jetway under any circumstances. I only bought mine because i was originally trying to squeze a system into a micro-atx case that i had laying around. It ended up that my CD drive wouldn't go in because of the CPU heatsink so I had to upgrade to a new Antec case anyway.

    Atleast the motherboard was cheap.

    Taking suggestions for a new mother board that supports Legacy USB.... anyone have one? I am thinking of going with Asus.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2005
    Posts
    3

    revised solution

    I am posting this with hope that it may help others having the same problem.

    -- make a GRUB boot disk for each additional OS you want to boot into
    -- then just change the default OS that GRUB boots into -- (check 'menu.lst' found on your floppy).

    for example...
    1 - XP is my default for booting from the harddrive.
    2 - Suse is one floppy disk
    3 - Fedora Core is another.

    Not the most ideal solution, but it certainly allows me get by without the USB Legacy support.

    if you want more detailed instructions on how to setup a boot floppy consult with
    http://www.gnu.org/software/grub/gru...faq.en.html#q4

    Jason

  6. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    6
    I guess I might be silly with my answer.
    Try to Unplug your AC cable off your PC for a while and change the USB keyboard input to another one, reblug your PC to the AC and start it. If that didn't work try this
    start your computer and after seeing the bootloader turn off you computer and turn of again (Not RESET botton) I hope that will help
    I know this is silly but I tried that with me and it did work by using the first way.

  7. #6
    Just Joined!
    Join Date
    Nov 2006
    Posts
    1

    Smile Legacy USB Support Worked for me

    I just found this thread (thank you, Google) and had the exact same issue. I have an ASUS A7N8X Deluxe and the boot loader wouldn't recognize my USB keyboard, but had no problems with the PS/2 one.

    I enabled Legacy USB support in my BIOS and now everything's working great!

    Thanks, all! Hope this helps others!

  8. #7
    Just Joined!
    Join Date
    Jun 2004
    Posts
    4
    hmm, guess I'll try this. I'm also glad Google spiders forum threads.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •