Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Location
    Maputo, Mozambique, Africa
    Posts
    19

    Help installing sms pluging into gaim and libglib2.0_0-devel


    Hi,

    I'm having problems installing a sms pluging into gaim instant messenger. So, I'll explain step-by-step what I have done, and hope somebody can help me:

    I've downloaded a gaim instant messenger plugin that allow sending me sms's. The file is named "gaimsms-0.01.tar.gz" and have the following installation notes:
    1. Place gaimsms.c in the plugins directory of a copy of the gaim source.
    2. Run ./configure on your copy of the gaim source if you haven't already.
    3. Modify the Makefile in the plugins/ directory in the following way:
    add -lcurl to your LIBS line so that it looks something like this:
    LIBS = -lcurl
    4. Run make gaimsms.so
    5. Copy gaimsms.so to your gaim plugins directory (either /usr/local/lib/gaim or /usr/lib/gaim )
    6. Select it from the list of plugins during runtime and add your phone number
    So, when I'm on step two (./configure) I found the following error:
    Code:
    [root@cust204-15 gaim-1.2.1]# ./configure
    .......... very long checking output  ................ and the error is .....
    checking for GTK+ - version >= 2.0.0... no
    *** Could not run GTK+ test program, checking why...
    *** The test program failed to compile or link. See the file config.log for the
    *** exact error that occurred. This usually means GTK+ is incorrectly installed.
    configure: error:
    *** GTK+ 2.0 is required to build Gaim; please make sure you have the GTK+
    *** development headers installed. The latest version of GTK+ is
    *** always available at http://www.gtk.org/.
    [root@cust204-15 gaim-1.2.1]#
    I make a google search in some forums, and I found that I need "libglib2.0_0-devel".

    I try to check the version of glib that I've installed:
    Code:
    [root@cust204-15 gaim-1.2.1]# urpmq -r --list | grep "libglib"
    libglib1.2-1.2.10-14mdk
    libglib2.0_0-2.4.6-1mdk
    [root@cust204-15 gaim-1.2.1]#
    So, I search for devel package of "libglib2.0_0-2.4.6-1mdk", and I found the file "libglib2.0_0-devel-2.4.6-1mdk.i586.rpm" and his dependence "glib-gettextize-2.4.6-1mdk.i586.rpm".

    I install this two rpm's whitout errors.

    and I think: now that the devel package is installed, let's run again the command ./configure

    I run the command, and I receive again the same error (that I've put on the top of this message).

    My question:
    - The package libglib2.0_0-devel-2.4.6-1mdk still unistalled?
    - How can I confirm that?

    I try the command {"urpmq -r --list | grep "libglib"} hopping to see the package "libglib2.0_0-devel", but nothing. The result still the same:
    Code:
    [root@cust204-15 gaim-1.2.1]# urpmq -r --list | grep "libglib"
    libglib1.2-1.2.10-14mdk
    libglib2.0_0-2.4.6-1mdk
    [root@cust204-15 gaim-1.2.1]#
    Can somebody help me with this?
    Thanks, AkiL

  2. #2
    i think the problem is that gtk(the entire thing) is installed, but gaim can't find it. I had a similar problem were it was using the pkgconfig from /usr/local/pkgconf rather than /usr/pkgconfig...... I could solve it
    Brilliant Mediocrity - Making Failure Look Good

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •