IBM xSeries 205 - Adaptec AIC-7892P U160


Hi,

i have the following hardware config:
* IBM xSeries 205 Server
* Adaptec AIC-7892 SCSI raid controller
* IBM hard disk

i tried to install debian from a sarge/testing net install. With the first distribution (i can't exactly tell which one) it said it can't find any hard disk to partition. I started the install procedure with the aic_7xxx=no_reset parameter.

i then tried a newer net install set (date is 8th may 2005). With this one, the adaptec driver loaded and i could finally partition my harddrive. But then it said it can't detect my network adapter first, and next it couldn't detect all other hardware. I continued the installation, and with the next reboot the hardware drivers seemed to reboot correctly. It then loaded IPv6 and every time i tried to apt-get something, it first tried a very long time to go out via the v6 protocol, which didn't work.

I then compiled my own kernel (without IPv6 *grin*) and it seemed to work fine, until i started working on iptables and i wanted to look if /proc/sys/net/ipv4/ip_forward was set to 1 or 0. I then realized that the whole /proc/sys/ directory was missing.

My questions are the following:
* is there a way to "install" or "re-install" the /proc/sys directory without completely reinstall the system (as i fear it wouldn't solve the problem)
* does anyone know a debian installer that works with such a hardware configuration ?

Else i think i will try to put a small IDE disk in the server and install the system on it, and then use the SCSI disk only for datas.

Thanks for reading this

Marcel