Find the answer to your Linux question:
Results 1 to 7 of 7
I got some questions about linux. I downloaded a system monitor utility called gkrellm and i want to know how to make it start automatically when i log in. The ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Location
    Cyprus
    Posts
    96

    Linux Questions


    I got some questions about linux. I downloaded a system monitor utility called gkrellm and i want to know how to make it start automatically when i log in. The other thing i want to know is if adding this line "options ide-cd dma=1" in /etc/modules.conf is supposed to enable my dma on my dvd rom. I have a dvd and a cdrw which are dvd=secondary slave , cdrw=secondary master.
    Finally does anyone know where i can find a guide to put ttf fonts in red hat 9. I searched the internet and found a lot of guides but not specifically for red hat 9 and all of them follow a different approach which leads to different results. Some work some don't while others do half the job (i can see the fonts in some appz like open office but i can't see them in the system settings menu so that i can use them in kde desktop).
    Anyone knows a guide that works so that all appz can see the ttf fonts and it was tested in red hat linux plz help. I really hate the fonts in mozilla
    Thanks!

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    How to make something start at login is different from DE to DE. So, what DE are you using?

    "options ide-cd dma=1" will _not_ enable DMA on the CDs. To enable DMA (if it isn't automatically enabled anyway), run "hdparm -d1 /dev/hdc", providing that your CD-ROM is /dev/hdc, of course. To check whether DMA is enabled, run "hdparm -d /dev/hdc".

    For a guide on how to install TTF fonts, see this:
    http://www.tldp.org/HOWTO/TT-XFree86.html
    However, for Mozilla to use font antialiasing, if that's what you want, you will need to recompile it, passing "--enable-xft=yes" to configure.

  3. #3
    Just Joined!
    Join Date
    Jun 2003
    Location
    Cyprus
    Posts
    96
    I don't mean to be such a nOOb but what is DE? If you mean Desktop Enviroment i am using KDE that came with my Red Hat 9 distro.
    About mozilla i am thinking of downloading the tarball of the latest version.
    So if i got it right in order to have ttf fonts in mozilla i should:
    ./configure --enable-xft=yes
    make
    make install
    Is this correct?
    Should i unistall mozilla 1.3 before installing 1.4 or it doesn't matter?
    Thanks for your ansewer Dolda2000. You saved me again!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I did mean desktop environment. Sorry, but I only use GNOME, so I don't know how to make programs autostart in KDE. A regular KDE user will have to help you with that.

    As for mozilla, you're basically correct, but I think that you would like to pass it --enable-crypto as well, in order to get HTTPS support. They have turned it off by default because of export restrictions on strong ciphers.
    It might be wise to uninstall 1.3 in advance. Mozilla is a bit tricky, and sometimes different installers install it to different directories, and you don't want to have two versions of it lying around.
    Note that Xft support isn't really truetype support, although it is related to truetype. It doesn't make mozilla use more truetype fonts than before, but it makes it render the fonts with antialiasing, ie. smoothing the edges of fonts.

  6. #5
    Just Joined!
    Join Date
    Jun 2003
    Location
    Cyprus
    Posts
    96
    I accidentally removed the KDE Keyboard Tool that is used for changing between keyboard layouts and i can't switch to my second language. I tried different key combinations in the Control Center / Regional & Accesibility / Keyboard Shortcuts but nothing works. It worked fine before i shutdown the KDE applet.
    All my efforts in getting it back failed. Anyone knows where it is so that i can make it active again? Its getting really frustrating!
    Thanks.

  7. #6
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    While we're on the subject, how do you make things autoload in Gnome Dolda? I have the same system monitor and I would also like to make it load all by its pretty self...

  8. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    To make stuff run on startup in GNOME, go to the session manager preferences (in GNOME2 under RH8.0 you can find it under Main Menu->Extras->Preferences->Sessions), and add stuff to the list under "Startup Programs". Also, for XSM-aware programs, you can just set up your desktop the way that you want it to be when you log in, then log out and check the "Save current setup" checkbox. Then everything will (read: should) be restored the next time you log in. I think KDE has a similar feature, but I'm not sure.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •