Find the answer to your Linux question:
Results 1 to 6 of 6
Dear All, Question ======== I downloaded the slackware iso and do not have a burner. The boot disk works but the root disk hangs. Slackware Installation FAQ's suggests you issue ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    nd
    nd is offline
    Just Joined!
    Join Date
    Aug 2003
    Posts
    3

    Installing Slackware 9 iso without a burner


    Dear All,

    Question
    ========

    I downloaded the slackware iso and do not have a burner. The boot disk works but the root disk hangs.

    Slackware Installation FAQ's suggests you issue these commands:

    mkdir -p /dos
    mount -t vfat /dev/hda1 /dos
    cd /dos
    mknod /dev/loop0 b 7 0
    mkdir /INSTALL
    mount -o loop /dos/install.iso /INSTALL

    Which I tried but failed.

    1stly. I don't understand what it does
    2ndly. It complains loop0 already exists. So does loop1.

    How do I get around this?


    Background
    ===========

    I am currently trying to get an operating system that meets the following objectives:

    1. Stable and Efficent
    2. Secure - in fact a bloody fortress
    3. Supports all my current hardware
    4. Is a development environment. Such as hosts jsp's. Eventually share on Samba and nfs but leave that for now.
    5. Does chew up my finite time to setup or maintain
    6. Teaches me OS clobber. Not neccessarily gentle way but rather in a way that does not make me very confused.

    In order to achieve this I was reccomended Slackware. However since I have never really used unix to this depth I decided to install redhat iso 9 which works. even managed to get the boot sector working.

    From here I am going to install Slackware 9 and ultimately Linux From Scratch. The machine must remain a multi boot with windows.


    Additional
    ==========

    Also if you could suggest help, or at least point me in the right direction it will be appreciated.
    I would also like comment on quality, content or presentation of posting.

    ==========

    Many Thanks,

    nd

  2. #2
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    Try any /dev/loop's upto /dev/loop7 - see how that goes.

    Your posting style i would define as "Clear and Polite", which is a good thing - possibly OTT with some of the background stuff, definatly better than being too vague i suppose. Overall ok.

    Welcome to the site.

    Jason

  3. #3
    nd
    nd is offline
    Just Joined!
    Join Date
    Aug 2003
    Posts
    3

    Didn't work

    Tried:

    mknod /dev/loop0 b 7 0
    through to:
    mknod /dev/loop7 b 7 0

    But none worked. What does this actually do anyway? How do I install slackware from redhat wothout a burner.

    I would also like to say how user-friendly red hat 9 is. Alot better than its predecessor. User is hidden from the depths of linux which would suit many folk, could help the us get the world on the other side.

  4. #4
    nd
    nd is offline
    Just Joined!
    Join Date
    Aug 2003
    Posts
    3

    I need installation help

    I am trying in vain to install slackware but no luck.

    The rootdisk that uses color.gz hangs.

    I a simply can't find the text.gz

    While umsdos install.zip is as of yet beyond me. It doesn't come with the vmlinuz which it says it does. The initial readme.txt file says 'This will someday be a README file.'

    What do I do? I have tried myself but no such look.

    And what does:

    mknod /dev/loop0 b 7 0

    do?


    Yours confused,

    nd

  5. #5
    Just Joined!
    Join Date
    Aug 2003
    Location
    Cowpens, SC
    Posts
    96
    according to "Linux in plain English", mknod is a command used to make special files. I have no idea what the 'b 7 0' does.

  6. #6
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496

    Re: I need installation help

    Quote Originally Posted by nd
    And what does:

    mknod /dev/loop0 b 7 0

    do?
    Summarized from http://www.cpqlinux.com/dev.html, this creates a device node for the loopback interface.

    b is for a block type (CD rom, drives, etc) - as opposed to c for character (terminal window, etc)
    7 is the major number or which driver to call (similar to IRQ)
    0 is the minor number which tells the driver which device you want

    You only need to create them if they don't already exist, and it sounds like yours already do.
    \"Everything should be made as simple as possible, but not simpler.\"
    Albert Einstein

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •