Find the answer to your Linux question:
Results 1 to 9 of 9
hie i got a problem, and the problem is that i can't play me cds on my linux. When ever i insert the disk in the CDROM the cd Player ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    8

    playing cds


    hie
    i got a problem, and the problem is that i can't play me cds on my linux. When ever i insert the disk in the CDROM the cd Player automatically props up but gives me an error i.e it prints out the error as DRIVE ERROR.
    After that it prompts me to set the device, to the appropriate one. On doing so i set my device to /dev/hdb which i believe is the correct path to my device, but on trying to play the CD again i get an error saying that I DON"T HAVE PERMISSIOM TO ACCESS /dev/hdb. So that's where i'm stuck at. If there is anyone out there who can help me pliz do so.
    chao

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    8
    By the way i use fedora core 3.

  3. #3
    Linux Newbie
    Join Date
    Jun 2005
    Posts
    181
    Include your user in the correct group.. Should be something like disk, or drives.

  4. #4
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    you might allso want to add the user to the audio groupe.
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  5. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    8
    i was wondering if u can give me so detailed procedures on how to do that, because i only started using linux recently.
    chao

  6. #6
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Ususaly you can add users to a group by editing the /etc/group (as root) and adding your user name to the groups you want to be in.

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  7. #7
    Just Joined!
    Join Date
    May 2005
    Posts
    8
    cool, i did that and now i can access my cdrom, however no sound is output when i try playing my audio cds. I tried ripping the cds and playing the .ogg files amd they do produce sound meaning that my problem has to be based on setting the output of sound from the audio cd.

  8. #8
    Linux Newbie
    Join Date
    Jun 2005
    Posts
    181
    Hmm.. For starters make sure you're included in the audio group. Also check your CD drive is connected to the sound card? (you can play audio CDs without that on windows, but I dunno about linux).

  9. #9
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Quote Originally Posted by Monkeh
    Hmm.. For starters make sure you're included in the audio group. Also check your CD drive is connected to the sound card? (you can play audio CDs without that on windows, but I dunno about linux).
    I have two cd-roms, one connected to the sound-card (embedded in the motherboard) and one not. It seems like linux can play CDs from the connected one and not the not-connected with the basic CD-players which come with gnome and KDE, but if you try xine or a xine frontend it should work anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •