Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
ok you prob heard this question 9 million times, but i got a windows partition how do i mount it? or better still have an icon on my desktop that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    tim
    tim is offline
    Just Joined!
    Join Date
    Jan 2003
    Posts
    26

    mounting windows partition


    ok you prob heard this question 9 million times,

    but i got a windows partition how do i mount it?

    or better still have an icon on my desktop that will lead to the drive.

    its the first partition on the drive, thanx!



  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Just "mount -t vfat /dev/hda1 /mnt/win" to mount it on /mnt/win, but you can of course change the last one to wherever you want. You might want to consider adding it to /etc/fstab, though. See fstab(5) for more info.

  3. #3
    tim
    tim is offline
    Just Joined!
    Join Date
    Jan 2003
    Posts
    26
    thank you very much!


    is it poss to make it a link on the desktop? i know it is, or is it a bit harder?

    or again i know its poss, how do i let linux mount it on start up?



    i dont beleive this, couple years ago i knew how to do this, oh how windows has "cooled" me down...

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It was for boot time mounting that you should consider /etc/fstab. When you have done so, I think nautilus automatically creates a desktop link.

  5. #5
    tim
    tim is offline
    Just Joined!
    Join Date
    Jan 2003
    Posts
    26
    ok cheers thanx!

  6. #6
    tim
    tim is offline
    Just Joined!
    Join Date
    Jan 2003
    Posts
    26
    ok problem!

    taken me ages to get back to here


    after creating the "win" folder in /mnt/

    i then went and did what you said however this came up:

    [root@localhost root]# mount -t vfat /dev/hda1 /mnt/win
    mount: wrong fs type, bad option, bad superblock on /dev/hda,
    or too many mounted file systems


    so i thought, im using XP it uses NTFS not fat32 but then this came up:

    [root@localhost root]# mount -t ntfs /dev/hda1 /mnt/win
    mount: fs type ntfs not supported by kernel


    hmmm....please help!

  7. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Yes, ntfs still has EXPERIMENTAL status in the kernel tree, and write support has DANGEROUS status. Unless you're trying to fix the driver, you should never mount a ntfs partition writable.
    I would imagine that some distros ship without the ntfs driver at all. You'll have to build it yourself from the kernel sources if that's the case.
    The reason why NTFS is so poorly supported in linux is that there is no tech papers on it, so everything has to be reverse-engineered. Microsoft is keeping it a secret for some very good reason.

  8. #8
    tim
    tim is offline
    Just Joined!
    Join Date
    Jan 2003
    Posts
    26
    ok!

    well cheers for that anyway!

  9. #9
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    tim, try modprobe ntfs. You need to load the kernel module before you can mount it. As said before, don't attempt to write to the drive. I have had no problems reading from ntfs though.

  10. #10
    tim
    tim is offline
    Just Joined!
    Join Date
    Jan 2003
    Posts
    26
    all i want to do is to read to "grab" things of the drive i wont write to it, cos i just write to the linux side.

    where do i get this module + is it easy to install or do i have recompile the kernel...

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •