Find the answer to your Linux question:
Results 1 to 8 of 8
i've recently installed redhat 8.0 after trying mandrake linux. I have an onboard sound cand which i've disabled through bios and a hercules soundcard. System can see both (before i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2003
    Posts
    10

    redhat 8.0 problems..


    i've recently installed redhat 8.0 after trying mandrake linux.

    I have an onboard sound cand which i've disabled through bios and a hercules soundcard.
    System can see both (before i disable the onboard codec) but i have no sound.. what can i do for this?

    my hp3420 printer doesn't work also. how can i install it?

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Providing that there's a driver for it, the sound card can be configured using RedHat's soundcard detection program, which can be found under the application menu and "System Settings".
    The printer can likewise be installed with the "Printing" application in the same menu. I don't know if there's a specific driver for that printer, but considering that it's HP, it's probably compatible with the HP LaserJet Series II, which there is a driver for.

  3. #3
    Just Joined!
    Join Date
    Jan 2003
    Posts
    10
    found more problems..

    1. i have a teac CD recorder [master] and a samsung DVD player [slave]
    on my mobo..
    no problem in reading CDs from both drives but when it comes to copy a CD from the DVD drive the program in redhat can't see it..
    is there a DVD player for redhat??

    2. i have the gcc package. how can i install it so as to program in C++ and Java?

    3. what else do i need to have a Unix environment (kde?)

    thank you

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Jul 2002
    Location
    Daytona Beach, FL
    Posts
    487
    1)
    you can set redhat to see the dvd as a scsi device to burn from by passing the kernel a boot a paramater when you boot

    kernel /vmlinuz-2.4.18-19.8.0 ro root=LABEL=/ hdc=ide-scsi

    that tells hdc to be emulated as a scsi device, if i want to burn cd to cd i boot with

    kernel /vmlinuz-2.4.18-19.8.0 ro root=LABEL=/ hdc=ide-scsi hdb=ide-scsi

    the problem I have with this, is then i either cant play DVD's or they play lousy, i forget which

    2)
    if you have the gcc rpm do

    rpm -ivh gccxxxxx.rpm

    3) not sure what you mean, kde is a window manager - a graphical layer on top of the text default, what exactly are you looking for here?
    majorwoo

    Quiet brain, or I\'ll stab you with a Q-tip.

  6. #5
    Just Joined!
    Join Date
    Jan 2003
    Posts
    10
    ok.how will i do these in order to set the dvd as a scsi and where i type these phrazes? (and the phraze for the gcc you mentioned)

    what i mean for 3) is i need a unix environment. where i'll find that in redhat?? to be exact what do i need to have a unix env in linux??

    thank you

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    1)
    What majorwoo meant was that it was supposed to be passed to the kernel as a kernel command line parameter. If you're using GRUB as your boot loader, which I suppose you do, you will find the configuration file in /boot/grub/grub.conf, where you'll see where to add it.

    2)
    It's possible that you already have the java and c++ packages already installed if you have gcc installed. By the way, did you mean that you have gcc installed, or that you have the RPM so that you can install it when you want to? Anyway, the c++ and java extensions are in the packages "gcc-c++" and "gcc-java", respectively. To check if they are installed, run this (in a shell):
    Code:
    rpm -qa | egrep 'gcc-(c\+\+|java)'
    If they aren't installed, you can just install them from your installation CDs. Just insert one of them and go with the autorun, and the redhat package manager will show up.

    3)
    What do you mean with a unix environment? All variants of Linux that I know of (except possibly uCLinux...) are full-fledged unix environments as they are, since that's what they're designed to be. Is there some specific aspect you're looking for, since you're asking?

  8. #7
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    I think he means he wants a terminal. Anyway for scsi emulation to work on the cd drive, make sure you have the proper kernel modules loaded. I don't know if redhat will load them for you but I know my distro didn't.

  9. #8
    Linux User
    Join Date
    Jul 2002
    Location
    Daytona Beach, FL
    Posts
    487
    as dolda told you, if you are using grub (which is defautl with redhat 8 so you probably are)

    edit /etc/grub.conf and where you see a line similar to

    kernel /vmlinuz-2.4.18-19.8.0 ro root=LABEL=/ hdc=ide-scsi

    add hdb=ide-scsi

    kernel /vmlinuz-2.4.18-19.8.0 ro root=LABEL=/ hdc=ide-scsi hdb=ide-scsi

    (assuming you have a normal setup, if may need to be hdd - check

    [josh@woo josh]$ ls -l /dev/cdrom && ls -l /dev/cdrom1
    lrwxrwxrwx 1 root root 8 Dec 7 16:52 /dev/cdrom -> /dev/hdb
    lrwxrwxrwx 1 root root 9 Aug 29 09:14 /dev/cdrom1 -> /dev/scd0
    [josh@woo josh]$


    each of those will point to a /dev/ entry - make sure you add the one you need

    see in my case my kernel boot parameters told it to emulate scsi for /dev/cdrom1 so is labeled it /dev/scd0 (scsi device 0) as opposed to /dev/hdc (which is what would show up if i removed the hdc=ide-scsi line from my /etc/grub.conf file

    ----

    as for the unix environment - if you wanted a terminal you can go to teh menu, system tools, terminal -- if that is not what you want, please try to give us a better description of what exactly ou want
    majorwoo

    Quiet brain, or I\'ll stab you with a Q-tip.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •