Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
hi actually i was able to change the back ground in windowmaker. logged in as root i copied all the pics from the gnome background images folder into the background ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Aug 2003
    Location
    Lahore, Pakistan
    Posts
    146

    hi

    actually i was able to change the back ground in windowmaker.

    logged in as root i copied all the pics from the gnome background images folder into the background images folder of windowmaker.

    and it showed up...

    at a red hat forum of www.linuxiso.org, one of the guys told me one of the easiest way to install windowmaker.

    this is his reply to my query
    " hasan, The easiest way of doing this is to install atrpms-kickstart found here:
    http://atrpms.physik.fu-berlin.de/dist/rh9/
    After downloading it, install it this way>
    Open a terminal and type: su
    then your root password.
    Then type: rpm -Uvh atrpms-kickstart-9-3.i386.rpm
    Once that is installed, type: apt-get update Then type: apt-get install windowmaker
    Once this is done, log out. Then When you log back in, click on "session" and change it to "windowmaker"
    Theodore
    "

    thanks,
    hasan.

  2. #2
    Linux Newbie
    Join Date
    Aug 2003
    Location
    Lahore, Pakistan
    Posts
    146

    question to Dolda2000 Head Guru

    following r the instructions to install windowmaker on red hat 9.0

    i did not understand *2, *3, *4, *5, *7, *8

    please guide me how to do it. i did that apt-get install windowmaker .... it said can not fetch archive in the end

    i really need windowmaker on my red hat 9.0.

    - RedHat GNU/Linux
    RedHat systems have several annoying problems. If you use it,
    be sure to follow the steps below or Window Maker will not work:

    * if you installed the Window Maker that comes with RedHat, uninstall
    it before upgrading;

    * make sure you don't have the LANG and LINGUAS environment variables
    set to en_RN;

    * make sure you have /usr/local/bin in your PATH environment
    variable;

    * make sure you have /usr/local/lib in /etc/ld.so.conf before running
    ldconfig;

    * if you have problems that mention an error message with --no-reexec
    uninstall libtool-1.2b and install libtool-1.3 instead. libtool-1.3
    can be found in ftp.gnu.org Also read the TROUBLESHOOTING section;

    * if you installed the Window Maker package from RedHat and are
    installing a new version of it by hand (compiling yourself), uninstall
    the package from RedHat before.

    * make sure you have a symbolic link from /usr/include/X11 to
    /usr/X11R6/include/X11 (if not, type ln -s /usr/X11R6/include/X11
    /usr/include/X11 )

    * make sure you have /lib/cpp pointing to the cpp program

    If you have any doubts in doing any of the stuff above, please
    don't hesitate to contact the RedHat user support. They will
    kindly answer to all your questions regarding their system.
    They also know much more about their own system than us
    (we don't use RedHat).

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I haven't tried to install Window Maker, but it should work like this. Get this file:
    ftp://windowmaker.org/pub/source/rel...0.80.2.tar.bz2

    Start a terminal, extract the file with "tar -xvjf WindowMaker-0.80.2.tar.bz2", then cd into the newly created directory. Then run these commands:
    Code:
    su -c "echo /usr/local/lib >>/etc/ld.so.conf; ldconfig"
    ./configure
    make
    su -c "make install"
    That should do it. If you have an RPM version of Window Maker installed already, uninstall it first.

  4. #4
    Linux Newbie
    Join Date
    Aug 2003
    Location
    Lahore, Pakistan
    Posts
    146
    thanks dolda

    i will try that in 2-3 days and i iwill let u know.

    it would help us if u install window maker too on ur Red Hat 9.0. that way u will let know us what problems u ran into and how to fix them.

    one more thing, while using windowmaker on mandrake. logged in as a user, i tried to change the color of the focus bar [ the top bar of any application opened ]. i was successful but then, through that user some how i lost the configuration of windowmaker with kde and gnome. i was not able to launch anything through the windowmaker's menus.

    when i logged back as root. i saw windowmaker fully configured with gnome and kde. but the configurations with normal users was completely lost.

    b) 2nd thing is that why does real player work with red hat?

    i tried both the rpm installer as well as bin installer ....... it does not work. it shows its installing but it never initializes.

    real player got installed on mdk or anyother distro without any hasseles.

    thanks
    Hasan

  5. #5
    Linux Newbie
    Join Date
    Aug 2003
    Location
    Lahore, Pakistan
    Posts
    146
    ohh one more thing

    at what time during this configuration and compiling do we have to include the command to configure windowmaker with gnome and kde?

  6. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Configure with GNOME and KDE? How do you mean? If you mean that you want it to be compatible with GNOME and KDE window manager hints, then you should pass that to the configure script, like this:
    Code:
    ./configure --enable-gnome --enable-kde

  7. #7
    Linux Newbie
    Join Date
    Aug 2003
    Location
    Lahore, Pakistan
    Posts
    146
    so u mean during installation the code u told me earlier should look like this?

    Code:
    su -c "echo /usr/local/lib >>/etc/ld.so.conf; ldconfig"
    ./configure --enable-gnome --enable-kde
    make
    su -c "make install"


    and once the line " su -c "make install" " is entered, then i can log out and log back in by windowmanager?

    thanks,
    hasan.

  8. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I don't know if Window Maker will add its session scripts, actually. Try first and see if it does. If it doesn't just post back.

  9. #9
    Linux Newbie
    Join Date
    Aug 2003
    Location
    Lahore, Pakistan
    Posts
    146
    Dolda

    i did exactly as u said.

    i logged out and clicked on "session" to see if windowmaker is there.......

    there is no window maker !!!


    why isnt it showing up? if it got installed?

    why does redhat have to make their distro in a way that it starts to close out other packages?

    i forgot to tell u that i think from http://rpm.pbone.net/ i was able to find a windowmaker rpm to install. it did install and showed up in the list of desktop environment and window managers in session.

    but it was not configured to work with gnome and kde.

    let me find out that rpm again install using that.

    but can u tell a way to configure the windowmaker installed from an rpm to work with gnome and kde ?

    also redhat 9.0 does not allow real player to get installed

    thanks,
    hasan

    NOTE: now how do i remove windowmaker installed from a *.bz2 file ?

    in rpm we use rpm -e

    but to uninstall applications installed from non-rpm source. how do we do that?

  10. #10
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It's probably that WindowMaker doesn't ship any session scripts, since they have to be tailored a bit to the distribution. What display manager are you using (gdm, kdm or xdm)? If you don't know, run "ps -A | grep dm".

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •