Find the answer to your Linux question:
Page 4 of 5 FirstFirst 1 2 3 4 5 LastLast
Results 31 to 40 of 43
modprobe sb results = [root@localhost root]# modprobe sb /lib/modules/2.4.20-8/kernel/drivers/sound/sb_lib.o: unresolved symbol unload_uart401_Recfdd9c9 /lib/modules/2.4.20-8/kernel/drivers/sound/sb_lib.o: unresolved symbol uart401intr_R6391d066 /lib/modules/2.4.20-8/kernel/drivers/sound/sb_lib.o: unresolved symbol probe_uart401_R63d781ea /lib/modules/2.4.20-8/kernel/drivers/sound/sb_lib.o: insmod /lib/modules/2.4.20-8/kernel/drivers/sound/sb_lib.o failed /lib/modules/2.4.20-8/kernel/drivers/sound/sb_lib.o: insmod sb failed...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #31
    Just Joined!
    Join Date
    Aug 2003
    Posts
    34

    modprobe sb results =


    [root@localhost root]# modprobe sb
    /lib/modules/2.4.20-8/kernel/drivers/sound/sb_lib.o: unresolved symbol unload_uart401_Recfdd9c9
    /lib/modules/2.4.20-8/kernel/drivers/sound/sb_lib.o: unresolved symbol uart401intr_R6391d066
    /lib/modules/2.4.20-8/kernel/drivers/sound/sb_lib.o: unresolved symbol probe_uart401_R63d781ea
    /lib/modules/2.4.20-8/kernel/drivers/sound/sb_lib.o: insmod /lib/modules/2.4.20-8/kernel/drivers/sound/sb_lib.o failed
    /lib/modules/2.4.20-8/kernel/drivers/sound/sb_lib.o: insmod sb failed

  2. #32
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Huh?! I cannot possibly imagine that RedHat would release a kernel with unresolved dependencies in such a popular module. Try to run "depmod -ae" and then rerun "modprobe sb".

  3. #33
    Just Joined!
    Join Date
    Aug 2003
    Posts
    34
    ok I got the sound working

    after i installed the alsa drivers, I then had the ability to run sndconfig

    I used sndconfig --noprobe to disable autodetection because it will select the cs4610/1 driver that doesn't work

    I selected CS4232 driver with the following settings
    io=0x530
    irq=5
    dma=1
    dma2=0
    mpuio=0x300
    mpuirq=5

    the sound works, now on to the next problem

    video display is set as a generic laptop display panel 1280x1024 resolution
    thousands of colors
    31.5-67khz horizontal refresh
    50-75hz vertical refresh
    2956x3251 dpi

    Trident Cyber 9397 DVD (generic) 8mb

    problem is that when any game is displayed in full screen or at least in a window that encompases the majority of the screen, this happens

    aproximately 25% of the diplay area on the left side will remain clear and unafected. the remainder clones the next 1/2 inch across the remaining 75% of the screen and it will not reset untill you restart X, and you have to do a forced shutdown due to the fact that if you slect the log off/shutdown from the main menu, the menu is displayed in the middle messed up portion of the display


    any ideas or suggestions would be appreciated

  4. $spacer_open
    $spacer_close
  5. #34
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I found something that might be related. Try this:
    Open /etc/X11/XF86Config, look up the "Device" Section for your card, and add this to it:
    Code:
    Option "CyberShadow" "off"
    Then restart the X server (log out and press Ctrl+Alt+BkSpc) and try again.

    By the way, 3000x3000 DPI? Are you sure about that, or is your LCD actually less than half an inch in width? ;-)

  6. #35
    Just Joined!
    Join Date
    Aug 2003
    Posts
    34
    Quote Originally Posted by Dolda2000
    By the way, 3000x3000 DPI? Are you sure about that, or is your LCD actually less than half an inch in width?

    I am using gnome if I follow (redhat)(system settings)(display)

    ion the advanced tab is says

    "DPI (Physical Resolution) 2956 x 3251 dots per inch"

    it is a 13.7 TFT SXGA LCD, 1152x864 is its native resolution , 1280x1024 native with the enhanced video adapter, which is installed (at least claimed by IBM, I just wish they would have posted more info, like refresh rates and such), I can go lighter (1024x768, 800x600, etc) but screen expansion makes all the fonts and graphics look bad

    ithe default driver says it can go higher but I think this must be for an external display because iit will do it but not fit on the screen, (it has screen expansion but not screen compression...LOL)

  7. #36
    Just Joined!
    Join Date
    Aug 2003
    Posts
    34
    Quote Originally Posted by Dolda2000
    Open /etc/X11/XF86Config, look up the "Device" Section for your card, and add this to it:
    Code:
    Option "CyberShadow" "off"
    like this?

    Section "Device"
    Identifier "Videocard0"
    Driver "trident"
    VendorName "Videocard vendor"
    BoardName "Trident Cyber 9397 (generic)"
    Option "CyberShadow" "off"
    EndSection

    will give it a try, be right back

  8. #37
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Yeah, that's the idea.

  9. #38
    Just Joined!
    Join Date
    Aug 2003
    Posts
    34
    ok doesn't do it

    but the cntrl alt backspace does at least i dont have to do a forced shutdown


    any more ideas, should i restore the xfree file back to the way it was?

  10. #39
    Just Joined!
    Join Date
    Aug 2003
    Posts
    34
    Definitely the spec book could be more informative

    just says

    "13.7-inch. 64k colors, 1280x1024 pixel SXGA TFT color LCD"

  11. #40
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It's probably closer to 120 DPI or so. 3000 is an extreme value; I can assure you that there isn't a single monitor in the world with a resolution even close to that, but it's not very important anyway.

    If that didn't work, then you can restore the XF86Config file. Unfortunately, I don't know what to do about it then. Try googling around a bit and see if you can find anything about it.

Page 4 of 5 FirstFirst 1 2 3 4 5 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •