Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
Kinda summarizes it. I want to use Linux. I really do. The idea is cool, the programs are neat, and I KNOW I can eventually get it to do what ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2003
    Posts
    82

    Absolute frustration, if you can help I would appreciate it


    Kinda summarizes it.

    I want to use Linux. I really do. The idea is cool, the programs are neat, and I KNOW I can eventually get it to do what I want it to. It's just that everytime I turn around, I hit major problems.

    Linux seems to have MORE issues than Windows. I will explain.

    I got went to the bookstore to get a Linux book so I could get better background info on Linux, Unix, etc. Things like how to install, where to install, etc, by hand (as most updated drivers seem to need). Lo and behold, there was a book for $30 with Redhat 9.0 CD's on it, with everything I want. So I installed Redhat over my SuSE (no important data on it yet).

    My setup is that I have two HDD's, one with XP and the other with Linux. I use bios to swap from one to the other, so with SuSE I was up and running. However, my sound card didn't work (Audigy 2), and no 3-D graphics either (Ati 9800 pro). Figured what the hell, give Red Hat a try.

    I re-partitioned my hard drive (hdb) using the automatic setup, with the mount point on hdb as well. Maybe it should have been hda, but I want to keep it clean between the two. After installing Red Hat, it recognized my sound card (and it worked!!), not 9800 pro (generic VESA driver used instead). WHen it rebooted, all I got was the a GRUB prompt. Of course, I have no idea at ALL what to do with a GRUB prompt. Rebooted with floppy boot disk, which then loaded Linux. When I went to configure my network card (USB cable modem), Red Hat decided it wouldn't work anymore. I activated the card, then tried to run Mozilla.

    Here's where it gets weird. A message on the toolbar said mozilla was loading. A few seconds tick by, then the message disappears, and no mozilla. I tried a few other programs -- same thing. Can't even run a shell. No programs loading. The x-windows interface works, but nothing else will run or open. Figured I did something wrong, maybe some dependcies messed up, and tried to reinstall.

    Of course, re-partitioned everything, this time I installed the whole works. Took about 45 minutes. This time, even though I re-partitioned, I got no prompt to set up my user account, just the root.

    Reboot after install, and this time I see the word GRUB on the screen, with no prompt. Total lockup. So I try the re-created floppy boot, and am able to boot to Linux, and signed on as root (as far as I know the only account). Again, can't run programs shells etc. When I tried to log off (was going to try to re-sign on), it froze totally. No mouse movement, nothing.

    Kinda amazed me by the instability. I am not trying to pick on Linux, but I am surprised by the amount of trouble I am experiencing by a pretty much standard install without doing funky options and messing them up.

    Should I format the hard drive, and start entirely with a new slate? Hate to admit it, but with XP I don't even know how to format my other hard drive, as it is not recognized anymore by XP since repartitioning with Linux. (yes it is seen in BIOS without problem)

    System specs (if it matters): P4 2.6 800 FSB, 512 GB Ram, audigy 2, ati radeon 9800, Asus P4P800 mobo.

    Thanks for any ideas or sympathy!

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    In a way, Linux does have more issues than Windows. That's mainly because the majority of hardware vendors consider their work done once their hardware works with Windows. In Linux, the community normally has to recreate everything by hand, often with little or no support from the hardware vendors, and therefore things can often get a little wrong. Once Linux becomes more popular, that will most likely change, since hardware vendors might have to put a little effort into making their stuff standards compliant and create Linux drivers.
    If you have compliant hardware, then the chance of running into trouble with Linux is extremely small, on the other hand.
    The radeon cards are a typical example of this. ATi provides state-of-the-art drivers for Windows, but their Linux drivers are of really poor quality, simply because they don't really care.

    Your problems are still very strange, though. It seems that the installation isn't fully completed, but I can't say why at this point. When you installed, did you get a screen saying that it was going to reboot, or did it just reboot by itself without prior indication of it?

  3. #3
    Just Joined!
    Join Date
    Aug 2003
    Posts
    82
    It said it was going to reboot (like expected).

    I think I want to reformat the HD totally and start over. My suspicion is that the MBR has gotten weird with so many reinstalls. Or maybe superstition.

    Any ideas how to do this when Windows doesn't know the HD is there?

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Well, Windows can't read Linux partitions, so it would be strange had it detected it. Windows simply doesn't display anything it doesn't recognize as its own.

    You know what you can try? Try putting the Linux HDD as the only one (ie. remove the Windows HDD and make the Linux HDD primary) and reinstall. Just to see if it works, of course.

  5. #5
    Just Joined!
    Join Date
    Aug 2003
    Posts
    82
    Here's what I have done so far.

    Reinstalled (naturally).

    This time, said heck with it and put GRUB on dev/hba. Now I am using the loader to decide windows or linux. Linux (Red Hat) currently loads and the programs work. However, I am afraid to try to configure the network settings to make my connection work.

    I currently have a connection with a cablemodem, with a USB NIC. What Red Hat autodetects is a Pegasus adapter. What I have (according to Windows, and I think SuSE as well) is ADMtek. This is not in the device list I can drop down in the network configuration wizard. Of course, I could be doing it wrong, but I assume I set it up like am ethernet connection with this interface.

    Any ideas for a workaround? there doesn't seem to be a 'generic' NIC in the menus.

    I think this is what went wrong before, because I just let it go with what it detected. Soon after is when the weirdness began. It seems if I configure the network settings wrong, the WHOLE THING comes down. Won't even reboot.

  6. #6
    Just Joined!
    Join Date
    Aug 2003
    Posts
    82
    Just when I think I've won....


    I removed the USB NIC, and decided to switch to onboard LAN (I had it diabled in BIOS). Of course, I have the drivers for this on my install disk for windows.

    With a feeling of triumph, I found the Linux drivers at the ASUS website. I downloaded them, saved them the CDRW, then rebooted to Linux. Read the readme, and tried to follow along to install them. It failed.

    See if this makes sense to anyone else:
    " 1) Make sure that the kernel source is installed in /usr/src/linux or /usr/src/linux-2.4"

    What kernel source is this? I checked and there is no directory like this for me. Of course, when I did the rest (make install), I got a bunch of errors.

    Any more help ?

  7. #7
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    the source files for your kernel. downloadan rpm here or try ftp.redhat.com for a tgz version

  8. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The thing is that you probably have drivers that come with your distribution. Those onboard LAN boards usually use some common chipset. Check what "/sbin/lspci" outputs and post that here, please.

    The kernel source RPM comes with the distributions. You should be able to find it on the CDs under the name "kernel-source". But check the above first, though; you might not have to compile a driver at all.

  9. #9
    Just Joined!
    Join Date
    Aug 2003
    Posts
    82
    Okay, I guess this cements how much of a newbie I am but...

    I was able to find /sbin/lspci

    I have no idea what you want me to do with it. I tried to open it with a terminal window by navigating to that folder and typing its name in as a program (it is a binary), but that didn't work. How do I get the output you are asking for? I am learning lots, but still have some ways to go. Thanks for your patience.

    If it helps any, I am running Red Hat 9.0, version 2.4.20-6 smp. Although I have no idea what 'smp' means, even the thick book I got with it doesn't tell me that one.

  10. #10
    Just Joined!
    Join Date
    Aug 2003
    Posts
    82
    Nevermind, got lspci to work. Don't know what was going on. Maybe I should just relax eh?

    Here's an abreviated output:

    Host Bridge Intel Corp ..etc...etc.
    PCI Bridge Intel Corp unknown device 2571
    .
    .
    etc
    .
    etc
    .
    02:05.0 ethernet controller 3COM corporation: unknown device 1700 (rev 12)


    Like I said, there is a driver for download from the ASUS website for this onboard ethernet controller, but the actual installation of it is where I am stuck.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •