Find the answer to your Linux question:
Results 1 to 5 of 5
So, a month or so back my previous CD-ROM drive started thinking that refusing to read CDs would be the newest sliced cheese. I promptly figured (as it was old ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! Sykotik's Avatar
    Join Date
    Mar 2002
    Location
    Cape Town, South Africa
    Posts
    54

    CD-ROM woes


    So, a month or so back my previous CD-ROM drive started thinking that refusing to read CDs would be the newest sliced cheese. I promptly figured (as it was old already) that it was acting up, booted it out of the case and got me a new one, that being a run-of-the-mill A-Open 56x drive, from one of the other PCs in here. Before my mitts were on it, it was a month or two old and hardly ever used (the other PC already had a CD-Writer used as primary CD device).
    So I plug it in, and it works fine, except for every now and then struggling to find a CD, giving me input/output errors when trying to access it, and then complaining with "medium not found" to boot. Which usually went away after re-inserting the disc after a while.
    Well, now I can't read any CD. At the time, the device was on my second IDE bus, so I figured putting it on the primary could be worth a shot, to see whether the fault was with the IDE2. Still no luck.
    Normally I'd write this off as a faulty CD-ROM drive, but I mean heck, Jim, this thing is as good as brand spanking new!
    Any suggestions or will I just have to scrunge up money for a new CD-ROM?
    By the way, I am using supermount to access it, but then again, unmounting the SM and mounting as per usual doesn't help me much either.
    I guess it is a hardware error, but I'm kind of hoping against hope that someone here knows some magick trick

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Check if you're using DMA to access it. Is it /dev/hdc right now? In that case, check "hdparm -d /dev/hdc". Also check "hdparm -I /dev/hdc" (that's uppercase i, not lowercase L). What IDE chipset are you using? Some chipset drivers give extra information in a file in /proc/ide (for example, I have /proc/ide/via for my VIA IDE chipset). Check if it says something. Also, try to just dumb read a CD ("cat /dev/hdc >/dev/null"), and check what kernel errors you get during that time ("dmesg | tail").
    Just to gather some information.

  3. #3
    Just Joined! Sykotik's Avatar
    Join Date
    Mar 2002
    Location
    Cape Town, South Africa
    Posts
    54
    The device is /dev/hdb at the moment, still on my IDE1. Anyway, here's the output from all the commands:

    hdparm -d /dev/hdb
    Code:
    /dev/hdb:
     using_dma    =  1 (on)
    hdparm -I /dev/hdb
    Code:
    /dev/hdb:
    ATAPI CD-ROM, with removable media
            Model Number:       CD-956E/AKV
            Serial Number:
            Firmware Revision:  A93
    Standards:
            Likely used CD-ROM ATAPI-1
    Configuration:
            DRQ response: 50us.
            Packet size: 12 bytes
    Capabilities:
            LBA, IORDY(cannot be disabled)
            DMA: *sdma0 sdma1 sdma2 mdma0 mdma1 *mdma2 (?)
                 Cycle time: min=120ns recommended=120ns
            PIO: pio0 pio1 pio2 pio3 pio4
                 Cycle time: no flow control=240ns  IORDY flow control=120ns
    /proc/ide/via
    Code:
    ----------VIA BusMastering IDE Configuration----------------
    Driver Version:                     3.36
    South Bridge:                       VIA vt82c596b
    Revision:                           ISA 0x23 IDE 0x10
    Highest DMA rate:                   UDMA66
    BM-DMA base:                        0xe000
    PCI clock:                          33.3MHz
    Master Read  Cycle IRDY:            1ws
    Master Write Cycle IRDY:            1ws
    BM IDE Status Register Read Retry:  yes
    Max DRDY Pulse Width:               No limit
    -----------------------Primary IDE-------Secondary IDE------
    Read DMA FIFO flush:          yes                 yes
    End Sector FIFO flush:         no                  no
    Prefetch Buffer:               no                  no
    Post Write Buffer:             no                  no
    Enabled:                      yes                 yes
    Simplex only:                  no                  no
    Cable Type:                   80w                 40w
    -------------------drive0----drive1----drive2----drive3-----
    Transfer Mode:       UDMA       DMA       PIO       PIO
    Address Setup:       30ns      30ns     120ns     120ns
    Cmd Active:          90ns      90ns     480ns     480ns
    Cmd Recovery:        30ns      30ns     480ns     480ns
    Data Active:         90ns      90ns     330ns     330ns
    Data Recovery:       30ns      30ns     270ns     270ns
    Cycle Time:          30ns     120ns     600ns     600ns
    Transfer Rate:   66.6MB/s  16.6MB/s   3.3MB/s   3.3MB/s
    As for the dumb reading, I got two results: (first line is cat output, the rest is from dmesg)

    cat: /dev/hdb: No medium found
    cdrom: open failed.

    cat: /dev/hdb: Input/output error
    hdb: command error: status=0x51 { DriveReady SeekComplete Error }
    hdb: command error: error=0x54
    end_request: I/O error, dev 03:40 (hdb), sector 1347472

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Try turning off DMA and see if it works better.
    Code:
    hdparm -d0 /dev/hdb
    You can also try some different transfer modes after that.
    Code:
    hdparm -X1 /dev/hdb
    Or
    Code:
    hdparm -X8 /dev/hdb
    You can also try to decrease the disk rotation speed:
    Code:
    hdparm -E2 /dev/hdb
    These are just some tricks. They may or may not work.

  6. #5
    Just Joined! Sykotik's Avatar
    Join Date
    Mar 2002
    Location
    Cape Town, South Africa
    Posts
    54
    Meh. No luck there. Thankee anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •