Find the answer to your Linux question:
Results 1 to 5 of 5
I have been trying for some time now to make my Red Hat Linux distro view greek charactes in file names instead of those little ??????? signs. I have 2 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Location
    Cyprus
    Posts
    96

    File Names & Charsets


    I have been trying for some time now to make my Red Hat Linux distro view greek charactes in file names instead of those little ??????? signs. I have 2 NTFS partitions which i mounted as /mnt/Windows and /mnt/Backup and both of them contain files that are named in greek. I was browsing the internet and i found a tutorial to make it possible to view greek named files in partitions.
    The problem is that the tutorial was about SuSE 8.2 Pro and vfat filesystems.
    This is what i found (fstab):
    /dev/hda1 /mnt/Windows/C vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0
    The only thing that someone has to do to view greek named files according to the tutorial is to change the iocharset to iso8859-7.
    Well i tried in with my fstab configuration which is like this:
    /dev/hda1 /mnt/Windows ntfs ro,umask=0222 0 0
    and changed it like this:
    /dev/hda1 /mnt/Windows ntfs ro,umask=0222,iocharset=iso8859-7 0 0
    I tried to put the line code=437 but it gave me an error during boot so i erased it.
    I also installed some win ttf fonts that contain greek characters and changed all the system fonts to those and all the setting to iso8859-7 but again when i view the files i see little squares instead of the name.
    Am i doing something wrong or this doesn't work in Red Hat 9 / KDE 3.1 or at all?
    Any ansewer will be appreciated.

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It could simply be that your NTFS drives are encoded with utf-8. Try that instead of iso8859-7.

  3. #3
    Just Joined!
    Join Date
    Jun 2003
    Location
    Cyprus
    Posts
    96
    Well i tried this:
    iocharset=utf-8
    and this iocharset=UTF-8
    and i get an error for both of them during boot. Instead of the green OK i get FAILED when reading the fstab file and trying to mount the 2 ntfs partitions.
    Something about wrong fs type...

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Sorry, my mistake. That should be utf8, not utf-8.

  5. #5
    Just Joined!
    Join Date
    Jun 2003
    Location
    Cyprus
    Posts
    96
    Thanks Dolda2000 that worked great!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •