Find the answer to your Linux question:
Results 1 to 3 of 3
I'm having trouble getting mke2fs to run. I recently changed the partitioning of a drive that had a /boot partition at hdb1, an NTFS at hdb2, a swap at hdb3, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    7

    mke2fs woes


    I'm having trouble getting mke2fs to run. I recently changed the partitioning of a drive that had a /boot partition at hdb1, an NTFS at hdb2, a swap at hdb3, and / at hdb4 to remove the NTFS partition in hopes of formatting that space as ext3. Running cfdisk /dev/hdb gave me
    Code:
    FATAL ERROR: Bad primary partition 3: Partition ends in the final partial cylinder
                              Press any key to exit cfdisk
    so I opted for fdisk /dev/hdb instead. I (beileve I) successfully removed the NTFS partition, added a new partition in its place, rearranged the partition table, and wrote it to disk. After changing my GRUB configuration and /etc/fstab, my system still boots and has all my data, so that is fine. The current output from typing 'p' after running [b\fdisk /dev/hdb[/b] is
    Code:
    fdisk /dev/hdb
    
    The number of cylinders for this disk is set to 9964.
    There is nothing wrong with that, but this is larger than 1024,
    and could in certain setups cause problems with:
    1) software that runs at boot time (e.g., old versions of LILO)
    2) booting and partitioning software from other OSs
       (e.g., DOS FDISK, OS/2 FDISK)
    
    Command (m for help): p
    
    Disk /dev/hdb: 81.9 GB, 81964302336 bytes
    255 heads, 63 sectors/track, 9964 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/hdb1               1        5221    41937651    5  Extended
    /dev/hdb2            5222        5235      102816   83  Linux
    /dev/hdb3            5235        5299      512064   82  Linux swap
    /dev/hdb4            5299        9965    37484496   83  Linux
    
    Command (m for help):
    Now, though, when I try to run mke2fs -j /dev/hdb1, I get the following output:
    Code:
     mke2fs 1.35-WIP (07-Dec-2003)
    /dev/hdb1: Invalid argument passed to ext2 library while setting up superblock
    This happens both when I try to run the command from my installed distribution (SuSE 9.0 Pro) and when I run it from a LiveCD (BitDefender, a variant of Knoppix). I've tried it without the -j (even though I want ext3), and with -V and -n flags, as well as various combinations of these, but none have made any difference in the output. What's wrong here?

  2. #2
    Linux Newbie
    Join Date
    Jul 2004
    Location
    Scotland
    Posts
    144
    /dev/hdb1 appears to be an extended partition marker, this cannot be made into a ext3 (-j) filesystem as it contains the extended partitions, which must have some sort of data in them. However, I can't see these partitions from fdisk..

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Location
    Czech Republic
    Posts
    1

    RE: mke2fs Invalid argument passed to ext2 libr....

    I had identical problem. I found of, then when I make partition, then fdisk write "Re-read table failed with error 16: Device or resourece is busy. Reboot your system to ensure the partition table is update." When I rebooted, this problem vanished.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •