Find the answer to your Linux question:
Results 1 to 9 of 9
Hi everyone! I've just installed Redhat Linux 7.1 Professional Edition from a package I bought some time ago, but never got to install. When Ifinished the instalation, I upgraded the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2003
    Posts
    25

    Updating Redhat 7.1


    Hi everyone!

    I've just installed Redhat Linux 7.1 Professional Edition from a package I bought some time ago, but never got to install.
    When Ifinished the instalation, I upgraded the whole system via Update Agent (took about 250MB and 4 hours).
    The problem is that now mysystem is reacting strangely:

    1- The icons in the "desktop" have no name under them.
    2- 90% of the caracter sets don't work
    3- Pressing the Gnome Desktop Guide (the arrow icon next to the 4 desktop chooser) in the panel, I see multiple gmc instances (about 6) ¿is this normal?
    4- I'm not able to run the Update Agent anymore
    5- It won't run autorun CD's, though I told it to
    6- During the initial instalation, I chose a server install for web, mail, FTP, etc, but I can't find anything except Apache

    And last but not least... I don't know exactly up to what level is my system updated... ¿Can I somehow update it to version 9.0?

    Please help me, I've looked all over the internet, the Redhat web, forums, with no luck.


    Thank you very much in advance

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    1. I'm guessing that problems 1 and 2 are related to each other. How do you mean exactly that the character sets don't work?

    3. I believe so. It was a while since I was using gmc, but I believe that it will display one instance for each icon on your desktop.

    4. Could be that they've changed the SSL certificate. Check http://rhn.redhat.com/ for instructions on how to update it.

    5. Can you check so that magicdev is running?

    6. Find it? How have you tried searching for it? Can you telnet to localhost:25 and localhost:21?

  3. #3
    Just Joined!
    Join Date
    Sep 2003
    Posts
    25
    First of all thank you for answering so soon.

    Ok, points 1 and 2 solved by themseves after several reboots (¿is Bill around here too?). Hope they don't come back.

    Point 4, I've installed the certificate, but when I click on Update Agent, no window will open, or nor any sign of activity shows.

    Point 5, let me make shure I've explained my self right. Whe I inert a CD (ie the Redhat installation CD), it asks me I want to mount it. I say yes and I can open a "file manager" to see what's inside, but it will not autostart.
    In case you undestood me the first time... ¿how do I check to see if magicdev is running?

    Point 6, I have acces to an "apache configuration tool" through the panel. How do I manage MySqladmin to create databases (for example)

    The problem is that I'm new to this OS, and I'm trying to get used the new (for me) directory structure, etc.
    Also, it seems (for what I read in some places) that not all installations are the same, and that not always the same files go to the same directories.

    Basically, what I want to do is to have a web server with NUKE like I have on my Win2K.

    Thanks again.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    1&2. I probably should tell you that RedHat has known problems with internationalization, but it has been mostly apparent in RedHat 8 and 9. It seems strange that reboots would have cured it, but I'm not really surprised by anything that I hear about internationalization in RedHat anymore.

    4. Do you mean when you click the little circle in the notification tray or when you actually run up2date? up2date (another program developed internally by RedHat) depends on the RHN servers being responsive, so you must both have access to the internet and RedHat's servers must actually respond, which they don't always do, since the load on them is extremely high at times.

    5. Ah, OK. That's proof enough in itself that magicdev is running. In that case, it's kind of strange that it doesn't run the autorun file, though. Can you try mounting the RedHat CD, run the following command and post here what it says?
    Code:
    ls -l /mnt/cdrom/autorun
    6. Ah... well, what can I say? That "apache configuration tool" is just kind of a slap-on program that they have put on to apache to make it easier to configure. It is by no means the authoritative way to configure apache. The authoritative way is to edit the file /etc/httpd/conf/httpd.conf. That configuration tool displays a GUI where you can put options, and then it edits the file for you, but the normal way to do it is to edit the file with a text editor. It's very possible that there simply aren't any such GUI configurators for FTP and SMTP. FTP doesn't really have many options; try to FTP to yourself and see if it's enabled. SMTP is configured differently depending on what MTA is installed; the most common one is sendmail. Sendmail can generally be configured through either /etc/sendmail.cf or /etc/mail/sendmail.cf, depending on the version of RedHat; I believe that RedHat 7.1 uses /etc/sendmail.cf. Sendmail's configuration file format is wel known for being nightmarish, though, so you might want to go with the default configuration for now.

    Indeed, different distributions set up some programs to look for files in different places than they would by defauilt.

    What is NUKE?

  6. #5
    Just Joined!
    Join Date
    Sep 2003
    Posts
    25

    New Installation

    Thanks for the answers given before. I had this internet connection problem and coulden't connect til now to follow up.
    Since I had this problem, I worked around all my linux problems the "windows way". So I reinstalled, but this time (since I coulden't determine exactly how to solve the depedencies problems caused by PHP and PHP-NUKE) I installed everything (and I mean EVERYTHING).
    I configured Apache, PHP, MySql, PHP-NUKE, etc., and every thing works perfectly ( ).

    Since I installed everything, there are many things I will not be updating (I'll probably de-install them when I find out what they are and do).
    My questions are: ¿will I be better off doing it one thing at-a-time?, ¿shoud I start with the Kernel?. I suppose that I'll have to update all those features that are vulnerable because of their bugs, ¿is there a specific/recommended order in which they should be updated?.
    And finally, ¿what do you recommend, up2date or something like apt form rpmseek.com?

    Thanks again and in advance.

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Try up2date, it can't hurt. It should upgrade everything that needs to be updated in a good way.

  8. #7
    Just Joined!
    Join Date
    Sep 2003
    Posts
    25

    up2date

    Up2date was the one who messed things up in the first place.
    ¿Any alternatives?

    Thanks!

  9. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Oh yeah, that's right, it did. Sorry, I had forgotten that.

    Actually, I don't really know how else to do it; I upgrade everything by hand when I feel that it needs to be upgraded.

  10. #9
    Just Joined!
    Join Date
    Sep 2003
    Posts
    25

    Update

    Ok, thanks anyway. I'll keep on trying ad see if I'm able to update this without messing it up.

    Cheers!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •