Find the answer to your Linux question:
Results 1 to 7 of 7
Hi, Just installed Red Hat 8.0 on a Dell Laptop Inspiron 5150. I'm having trouble with sound playback on Xine and XMMS. I haven't tried any other programs. The sound ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2003
    Posts
    3

    audio problems


    Hi,

    Just installed Red Hat 8.0 on a Dell Laptop Inspiron 5150. I'm having trouble with sound playback on Xine and XMMS. I haven't tried any other programs. The sound plays too fast on xmms and on xine it skips while trying to slow down for the video.

    Any suggestions?

    Thanks

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2003
    Location
    Ontario, Canada
    Posts
    556
    what sound card is it?
    I've heard with yamaha for example you need to change it to 48000 hz. look in kde control center and then sound system. other than that I am not sure, check the xmms website tho, I have heard of this happening before.

  3. #3
    Just Joined!
    Join Date
    Sep 2003
    Posts
    3

    sound card

    The sound chipset is Sigmatel C Major. No luck on the XMMS website. The problem is not restricted to XMMS alone, so I guess it's not an XMMS bug.

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I'm sure that I've seen this before. I don't remember how it was solved, though. What sound driver are you using? If you don't know, check the output of "grep sound-slot-0 /etc/modules.conf".

  5. #5
    Just Joined!
    Join Date
    Sep 2003
    Posts
    3

    results

    [root@localhost /]# grep sound-slot-0 /etc/modules.conf
    alias sound-slot-0 i810_audio
    post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
    >/dev/null 2>&1 || :
    pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S
    >/dev/null 2>&1 | | :
    [root@localhost /]#


    That's what I got from running grep.

  6. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I don't have one of these chipsets to try anything on, but you can try playing a bit with the clocking. Add this line to /etc/modules.conf:
    Code:
    options i810_audio clocking=48000
    If that doesn't work, try to set clocking to 44100, or other values as you see fit, and see if that helps at all.
    When you have added it, and everytime you change it, run this command to update to changes:
    Code:
    rmmod i810_audio; modprobe i810_audio
    Note that you probably can't be logged in to any GUI while doing that, since it might hold the sound driver open.

  7. #7
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    who actualyl made your card, coz i would be suspicous of the driver and the sigmatel site doesnt have drivers coz they are the end manufacturer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •