Find the answer to your Linux question:
Results 1 to 10 of 10
that's the rror I get when trying to boot onto my 2.6.0-test4 kernel. The system then panics and says that it can't find any init. I can bodge my way ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190

    kernel 2.6.0-test4 - mount: error 19 mounting ext3


    that's the rror I get when trying to boot onto my 2.6.0-test4 kernel. The system then panics and says that it can't find any init.

    I can bodge my way around it by taking the initrd out of the grub.conf setup.

    Has anyone got any ideas of what I've done wrong?

    thanks

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  2. #2
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    did you build ext3 support into the kernel?

  3. #3
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    This page might help start you off http://www.vineyard.net/vni/docs/grub/errors.html , And why do you use an initrd image isnt that for boot disks??

  4. #4
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    my first thought was that I'd left off ext3, so I re-did the build xconfig (looks so much better now) and made sure that not only was ext3 in, but I had also checked the debug info box as well.

    Same result.

    Now, I've had something like this before when I forgot to put the underline in 'build modules_install' , but I am definately doing that (you get screens of *.ko modules being created and copied).

    As to why I'm using initrd, because I thought that that was the correct thing to do (my Redhat distro came with it). Is this not the case.

    thanks
    Nerderello
    ps. enjoying being a newbie again

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  5. #5
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    I guessed you where using Grub am i right? And ive never used initrd because i thought it was for RAM disks. And AFAIK for it to work you need unix PTY's enabled. Also you should disable loadable modules in the kernel there slower and can be a security risk.


    EDIT, Your answer > Just solved your problem, Whats wrong is you compiled ext3 support in as a module yeh? It needs to be compiled into the kernel cause when you boot it checks your file system but at this point your modules havent been loaded into the kernel so it wont work so just use a * not a m

  6. #6
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    yup, you're right. I got back from work ( a concept that is highly overated) and decided to go back to the 'good old ways' by doing a "build menuconfig" and sure enough, there it was, a "M" instead of a "*". In my defense I will say that I was using "build xconfig" for the first time in anger and hadn't quite got my head around the difference between a tick and a blob.

    Thanks guys for helping.

    Now all I've got to do is get the X working and I'll be happy.

    have fun

    Nerederello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  7. #7
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    guess what, my X problems were down to having the agpgart stuff as modules instead of in the kernel.

    Oh well, at least I'm learning how not to do it.

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  8. #8
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Glad to see that you're figured it all out. Stupid/careless mistakes like that are very common...especially when you're going through a kernel config...just remember to always compile in your chipset drivers...though I don't know anyone that would've forgotten that...
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  9. #9
    Just Joined!
    Join Date
    Oct 2007
    Posts
    11
    Hi nerderello,

    I am facing the following problem after installation of Fdero 4. Can you help me?

    Decompressing linux ..done
    Booting the kernal
    ..MP -BIOS bug : 8254 timer not connected to 10-APIC
    Red Hat nash version 4.2.15 starting
    mkrootdev:label/1 not found
    mount: error 2 mounting ext3
    ERROR opening, /dev/console !!!! :2
    error dup2' ing fd of 0 to 0
    error dup2' ing fd of 0 to 1
    error dup2' ing fd of 0 to 2
    switchroot : mount failed :22

    kernal panic - not syncing : Attended to kill init!

  10. #10
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi graja !

    Duplicate Threads/Posts are not allowed and this is a pretty old thread. Please continue here only. Thread Locked.
    Last edited by devils casper; 10-12-2007 at 01:26 PM.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •