Find the answer to your Linux question:
Results 1 to 3 of 3
I installed Fedora Core 2 a few days ago and am loving it. The problem is, I can't boot into XP. I am using Grub as my boot loader and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    2

    Can't boot Windows XP (Newbie)


    I installed Fedora Core 2 a few days ago and am loving it. The problem is, I can't boot into XP.

    I am using Grub as my boot loader and had my drive partitioned for Linux during install. I probably should have used Partition Magic, but was feeling way too adventurous to consider possible risk

    Fedora boots fine, but when I try to boot into XP I get an error message that one of the .dll files is missing and that I need to reinstall it. I don't recall which .dll, but if you need to know which one, I'll find out.

    I'm guessing I messed up the boot.conf file. However, a) I don't know how to fix it, b) I can't edit the file as I apparently don't have permission to even view it and c) I can't figure out how to change that permissions status or sign on as "owner" to get that permission. Weird to me, as I thought I set myself up as the one and only owner.

    Any suggestions on how this overly adventurous newbie can get his XP back would be much appreciated.

  2. #2
    Linux User PsypherPunk's Avatar
    Join Date
    Jan 2005
    Location
    Leeds, UK
    Posts
    257
    Tried rebooting from the XP CD and doing a repair installation?
    Registered Linux User #379728

    SuSE 10.3 :: Athlon XP 3000+ :: AsRock K7VT4A Pro :: Nvidia Geforce 6600GT :: C-Media 8738

    www.psypherpunk.org.uk

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    2

    re: doing a repair installation

    Quote Originally Posted by PsypherPunk
    Tried rebooting from the XP CD and doing a repair installation?
    I'm resistant to that idea, because I had a similar missing .dll issue last year that had my computer down for weeks. I tried the repair function off the XP CD and I can't remember exactly what happened, but all I remember is it went bad, very bad. I spent about a hundred hours trying to fix the cascade of problems that occurred. XP's "repair" function did not work as it was intended for some reason.

    So, that's in the back of my mind as a solution, but I was hoping it would be my last option after having exhausted other "safer" possible solutions.

    The last time I had this similar issue, now that I'm remembering, it was also because of my partitioning, but I used Partition Magic. Their tech guy walked my through redoing my boot.conf file and that helped it. So, I was hoping to cut right to the chase and fix the boot record or at least examine it to see if that's the problem. But, again, I can't even view it. Don't know how to change the permissions.

    Thanks for your super-speedy reply, and again any help would be much appreciated.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •