Of course how silly I should have remembered that windows FAT32 doesn't have file ownership features. That answers my chown question.

Now I tried the fstab with the folder name 'Documents" no spaces and still have read only privileges. The strange thing is my entire partition contents show up inside my Documents folder.

So if I'm setting the whole partition for user access (ideally I would prefer to config a couple of folders for full user access but it's not like I'm running a company network here so its ok for the whole partition); But why must I add a line to fsab. That would mean the win_c is configured twice! Should not I just edit the original win_c line instead?

I searched posts and found that security settings can impede access. My security seting at install was 'standard'. Would that interfere?

If this thread gets solved I will donate to the FSF gnu or plant a tree or something