Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Hi, I've got a problem with my sound card. It's a Guillemot Maxi Studio ISIS, which doesn't have Linux drivers. However, it's detected as an ESS Technology 1976 Maestro 2E ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2003
    Location
    Lille - France
    Posts
    24

    Sound problem : Maxi Studio ISIS


    Hi,

    I've got a problem with my sound card. It's a Guillemot Maxi Studio ISIS, which doesn't have Linux drivers. However, it's detected as an ESS Technology 1976 Maestro 2E (the same for MS-DOS ... I suppose it's good).

    I did as root : cat /proc/pci and here's the result :
    Bus 0, device 12, function 0:
    Multimedia audio controller: ESS Technology ES1978 Maestro 2E (rev 16).
    IRQ 11.
    Master Capable. Latency=32. Min Gnt=2.Max Lat=24.
    I/O at 0xec00 [0xecff].
    Then, I did : cat /etc/modules.conf and here's the result
    probeall usb-interface usb-uhci
    probeall scsi_hostadapter sym53c8xx
    alias eth0 ne2k-pci
    alias sound-slot-0 maestro
    And then, I did : cat /proc/modules
    ide-cd 33856 0 (autoclean)
    r128 83576 12
    agpgart 40896 3 (autoclean)
    maestro 30952 0
    soundcore 6276 0 [maestro]
    nfsd 74256 0 (autoclean)
    af_packet 14952 0 (autoclean)
    sr_mod 16920 0 (autoclean)
    cdrom 31648 0 (autoclean) [ide-cd sr_mod]
    floppy 55132 0
    ne2k-pci 6752 1 (autoclean)
    8390 7916 0 (autoclean) [ne2k-pci]
    nls_iso8859-15 4092 2 (autoclean)
    nls_cp850 4316 2 (autoclean)
    vfat 11820 2 (autoclean)
    fat 37944 0 (autoclean) [vfat]
    supermount 15296 3 (autoclean)
    usb-uhci 24652 0 (unused)
    usbcore 72992 1 [usb-uhci]
    rtc 8060 0 (autoclean)
    sd_mod 11548 0 (unused)
    sym53c8xx 66420 0
    scsi_mod 91796 3 [sr_mod sd_mod sym53c8xx]
    For me, everything seems to be okay ... but I can't have sound.
    I know the Guillmot's products aren't well supported under Linux.
    I'm running under Mandrake 9.1. Sound Server under KDE tells me that the sound device cant' be initialized and when I run artswrapper as root, it tells me that the sound device is busy.

    Please, could someone help me or give me a trick ?
    Thanks in advance and sorry for my bad English !

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    At least the driver loads, so I guess that that's a good sign. Also, since /proc/pci identifies it as an ESS card, maybe it is simply using an ESS chipset, in which case it should work.
    Start a terminal, run the following command and post back what it says, please.
    Code:
    ps aux >/dev/dsp
    If it says "Resource temporarily unavailable", please run this is well:
    Code:
    fuser -v /dev/dsp
    That last one needs to be run as root to work properly.

    You might also want to try the generic ESS driver inside the SoundBlaster module. To do so, run this as root:
    Code:
    rmmod maestro
    modprobe sb esstype=1978

  3. #3
    Just Joined!
    Join Date
    May 2003
    Location
    Lille - France
    Posts
    24
    I'm now under Gnome ...
    So, i did "ps aux >/dev/dsp" ... and nothing !
    Here's what I did :
    [root@localhost greg]# rmmod maestro
    maestro: Device or resource busy
    [root@localhost greg]# modprobe sb esstype=1978
    /lib/modules/2.4.21-0.13mdk/kernel/drivers/sound/sb.o.gz: init_module: No such device
    Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
    You may find more information in syslog or the output from dmesg
    modprobe: insmod /lib/modules/2.4.21-0.13mdk/kernel/drivers/sound/sb.o.gz failedmodprobe: insmod sb failed
    Any idea ?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Didn't it give you anything at all? That should mean that it really worked. Check if so that your mixer levels simply aren't at zero. They're set to zero by default, so it's a common error. One program that you can use is aumix (needs to be started from a terminal).

  6. #5
    Just Joined!
    Join Date
    May 2003
    Location
    Lille - France
    Posts
    24
    I already used aumix to check the sound level, but it didn't solve my problem.
    Here's the message I have when the sound server starts with KDE :
    Sound server warning message:
    Can't set real-time scheduling priority.
    You need to run artswrapper as root or
    setuid root. This means that you will
    likely not be able to produce acceptable
    sound (i.e. without clicks and breaks).
    But I can't launch artswrapper as root. Here's the message :
    [root@localhost greg]# artswrapper
    >> running as realtime process now (priority 50)
    Error while initializing the sound driver:
    device /dev/dsp can't be opened (Resource temporarily unavailable)
    I know that my soundcard my not work under Linux, but it seems I'm very close to find a solution.

    Thanks for help Dolda ... and give me any trick you have !

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Resource temporarily unavailable seems to indicate that something is blocking the sound device. Try running "fuser -v /dev/dsp" (as root) after you have run artswrapper and seen it failed.
    It could also be something with arts, and in that case I cannot help, since I don't use KDE.

  8. #7
    Just Joined!
    Join Date
    May 2003
    Location
    Lille - France
    Posts
    24
    Grrr ... there's no way to make this f***ing sound card to work.

    If you know another way (even if it's not under KDE), I'm listening to you Dolda !
    Thanks for help !

  9. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Can you run "cat >/dev/dsp" without receiving any errors?

  10. #9
    Just Joined!
    Join Date
    May 2003
    Location
    Lille - France
    Posts
    24
    No errors ... after a few seconds, it told me nothing and gave me the prompt ...
    What do you use Dolda ?

  11. #10
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I use GNOME, but I don't think that that is the explanation to this, since "ps aux >/dev/dsp" didn't make a sound for you. It was supposed to give off a short noise. The strange thing is that it gives you neither errors nor noise. That is why I thought that you mixer settings would be set at zero.

    Could you try to reload the driver module and then check with "dmesg | tail" if the kernel emits any information? Can you also check /proc/ioports and check if the range as reported by /proc/pci is claimed by the driver?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •