Find the answer to your Linux question:
Results 1 to 2 of 2
Trying to get gnome2.4 working... I ran across a problem i have had for quite some time now to do with esd. The problem is actually ALSA not detecting my ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2003
    Posts
    1

    ALSA Woes.


    Trying to get gnome2.4 working...

    I ran across a problem i have had for quite some time now to do with esd. The problem is actually ALSA not detecting my card.

    Ive recompiled and recompiled and recompiled my kernel. Eventually ive figured the best method of getting the sound card to marginally work is to just compile it into the kernel.

    In my dmesg i ran across this as being the root of my problems..

    kobject_register failed for Ensoniq AudioPCI (-17)
    Call Trace:
    [<c0245285>] kobject_register+0x55/0x60
    [<c02c6822>] bus_add_driver+0x52/0xc0
    [<c02c6cdf>] driver_register+0x2f/0x40
    [<c0252b37>] pci_populate_driver_dir+0x27/0x30
    [<c0252c1c>] pci_register_driver+0x5c/0x90
    [<c056d873>] alsa_card_ens137x_init+0x13/0x40
    [<c055479c>] do_initcalls+0x2c/0xa0
    [<c012c1cf>] init_workqueues+0xf/0x40
    [<c01050a4>] init+0x34/0x1d0
    [<c0105070>] init+0x0/0x1d0
    [<c0108ab5>] kernel_thread_helper+0x5/0x10

    ALSA device list:
    No soundcards found.
    Anyone get any idea or make any sense of that whatsoever?

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Seems like a kernel bug, actually. The call trace seems like a 2.5 or 2.6 kernel. Is that what you're using? In that case, it might be understandable that it doesn't work as it should.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •