Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
I have searched all night on Google for a solution to my problem and everyone's solution are always unclear when I search other forums. I used PM 8.0 to install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Location
    Central Canada
    Posts
    29

    Another dual boot problem


    I have searched all night on Google for a solution to my problem and everyone's solution are always unclear when I search other forums.

    I used PM 8.0 to install Ubuntu (Linux) at the beginning of the harddrive with a swap partition before that. I have some problems with Linux reguarding permissions. I can't put a file from the desktop to any of the folders it says permission denied. But that's not the main problem at the moment. I can't load WinXP. I choose WinXP and it does the loading bar then goes to

    xmnt2002 program NOT FOUND - SKIPPING AUTOCHECK
    autochk program NOT FOUND - SKIPPING AUTOCHECK

    ... then restarts the computer.

    I go to try to install WinXP and it says the partition is Inactive. I think that partition is now Hidden. Some people were talking about using fdisk to unhide the NTFS partition? How do I do this? Or does anyone have another solution? The dual boot menu is GRUB.

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Can you post your /boot/grub/grub.conf file? If Windows is not on the first partition of your boot drive, grub.conf needs to use the 'map' command (twice) to get it to work. The 'makeactive' command may fix the "partition is Inactive" problem, or you may need to run fdisk to set the "active" flag.
    /IMHO
    //got nothin'
    ///this use to look better

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Location
    Central Canada
    Posts
    29
    Quote Originally Posted by drakebasher
    Can you post your /boot/grub/grub.conf file? If Windows is not on the first partition of your boot drive, grub.conf needs to use the 'map' command (twice) to get it to work. The 'makeactive' command may fix the "partition is Inactive" problem, or you may need to run fdisk to set the "active" flag.
    Windows is the third partition and I have no idea how to get fdisk to run. My WinXP Startup Disk doesn't have it. My Win98 Startup Disk does but it says "Incorrect MS-DOS Version". You wouldn't happen to know how I could get to the fdisk utility?

    The "makeactive" command is there and I don't think it's working.

    Code:
    # menu.lst - See: grub(8), info grub, update-grub(8)
    #            grub-install(8), grub-floppy(8),
    #            grub-md5-crypt, /usr/share/doc/grub
    #            and /usr/share/doc/grub-doc/.
    
    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    #
    # You can specify 'saved' instead of a number. In this case, the default entry
    # is the entry saved with the command 'savedefault'.           
    default		0
    
    ## timeout sec
    # Set a timeout, in SEC seconds, before automatically booting the default entry
    # (normally the first entry defined).
    timeout		10
    
    ## hiddenmenu
    # Hides the menu by default (press ESC to see the menu)
    #hiddenmenu
    
    # Pretty colours
    #color cyan/blue white/blue
    
    ## password ['--md5'] passwd
    # If used in the first section of a menu file, disable all interactive editing
    # control (menu entry editor and command-line)  and entries protected by the
    # command 'lock'
    # e.g. password topsecret
    #      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
    # password topsecret
    
    #
    # examples
    #
    # title		Windows 95/98/NT/2000
    # root		(hd0,0)
    # makeactive
    # chainloader	+1
    #
    # title		Linux
    # root		(hd0,1)
    # kernel	/vmlinuz root=/dev/hda2 ro
    #
    
    #
    # Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST
    
    ### BEGIN AUTOMAGIC KERNELS LIST
    ## lines between the AUTOMAGIC KERNELS LIST markers will be modified
    ## by the debian update-grub script except for the default optons below
    
    ## DO NOT UNCOMMENT THEM, Just edit them to your needs
    
    ## ## Start Default Options ##
    ## default kernel options
    ## default kernel options for automagic boot options
    ## If you want special options for specifiv kernels use kopt_x_y_z
    ## where x.y.z is kernel version. Minor versions can be omitted.
    ## e.g. kopt=root=/dev/hda1 ro
    # kopt=root=/dev/hda2 ro
    
    ## default grub root device
    ## e.g. groot=(hd0,0)
    # groot=(hd0,1)
    
    ## should update-grub create alternative automagic boot options
    ## e.g. alternative=true
    ##      alternative=false
    # alternative=true
    
    ## should update-grub lock alternative automagic boot options
    ## e.g. lockalternative=true
    ##      lockalternative=false
    # lockalternative=false
    
    ## altoption boot targets option
    ## multiple altoptions lines are allowed
    ## e.g. altoptions=(extra menu suffix) extra boot options
    ##      altoptions=(recovery mode) single
    # altoptions=(recovery mode) single
    
    ## nonaltoption boot targets option
    ## This option controls options to pass to only the
    ## primary kernel menu item.
    ## You can have ONLY one nonaltoptions line
    # nonaltoptions=quiet splash
    
    ## controls how many kernels should be put into the menu.lst
    ## only counts the first occurence of a kernel, not the
    ## alternative kernel options
    ## e.g. howmany=all
    ##      howmany=7
    # howmany=all
    
    ## should update-grub create memtest86 boot option
    ## e.g. memtest86=true
    ##      memtest86=false
    # memtest86=true
    
    ## ## End Default Options ##
    
    title		Ubuntu, kernel 2.6.10-5-386 
    root		(hd0,1)
    kernel		/boot/vmlinuz-2.6.10-5-386 root=/dev/hda2 ro quiet splash
    initrd		/boot/initrd.img-2.6.10-5-386
    savedefault
    boot
    
    title		Ubuntu, kernel 2.6.10-5-386 (recovery mode)
    root		(hd0,1)
    kernel		/boot/vmlinuz-2.6.10-5-386 root=/dev/hda2 ro single
    initrd		/boot/initrd.img-2.6.10-5-386
    savedefault
    boot
    
    title		Ubuntu, kernel memtest86+ 
    root		(hd0,1)
    kernel		/boot/memtest86+.bin  
    savedefault
    boot
    
    ### END DEBIAN AUTOMAGIC KERNELS LIST
    
    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    title		Other operating systems:
    root
    
    
    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/hda1
    title		Microsoft Windows XP Home Edition
    root		(hd0,0)
    savedefault
    makeactive
    chainloader	+1

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817

    Re: Another dual boot problem

    Quote Originally Posted by serum
    I go to try to install WinXP and it says the partition is Inactive.
    Re-reading this, I'm confused: Is XP installed or not? Did you install it before or after you installed Linux?

    Try this:
    • >boot to the Grub menu and press an up/down arrow key to stop the countdown-to-default-boot
      >highlight the Windows entry and press 'e' to edit
      >highlight the line that reads 'root (hd0,0)' and press 'e' to edit
      >change 'root (hd0,0)' to 'root (hd0,2)' and press enter to accept change
      >press 'b' to boot

    That change is not permanent.

    From what I've read, you may need to install Windows to the first partition with Linux behind it.
    /IMHO
    //got nothin'
    ///this use to look better

  6. #5
    Just Joined!
    Join Date
    Aug 2005
    Location
    Central Canada
    Posts
    29
    I tried the (hd0,2) before and it came up with this...

    Code:
    Filesystem type unknown, partition type 0x82
    Error 13: Invalid or unsupported executable format
    I also tried different numbers.

  7. #6
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817

    Re: Another dual boot problem

    Quote Originally Posted by serum
    I used PM 8.0 to install Ubuntu (Linux) at the beginning of the harddrive with a swap partition before that....
    Quote Originally Posted by Grub
    Filesystem type unknown, partition type 0x82
    I think partition type 82 is swap. Can you boot to Linux and post the result of 'fdisk -l /dev/hda'? (that's a lower-case "L" for list)
    /IMHO
    //got nothin'
    ///this use to look better

  8. #7
    Just Joined!
    Join Date
    Aug 2005
    Location
    Central Canada
    Posts
    29
    Sorry, what do you mean "boot to linux"?

    When I start up my computer it comes to the GRUB menu with 4 options.
    1) Linux
    2) Linux Recovery Mode
    3) Linux Memtest
    4) WinXP

    And if I use a WinXP Startup Disk it, I think, activates the WinXP partition but I'm stuck in MS-DOS.

    Also to answer the question earlier: "Is WinXP installed or not?". Yes it is. I thought I had messed up my computer so I went to reinstall WinXP on its partition and it said it would not because the partition was inactive etc.

  9. #8
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Go to GRUB and select Linux. Login as root and type:

    Code:
    fdisk -l /dev/hda
    Please post the output here.

  10. #9
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Quote Originally Posted by serum
    Sorry, what do you mean "boot to linux"?
    Any way that you can get a Linux command line will do. Can you select the first Grub menu item (Linux)? If not, will the second (Linux Recovery Mode) work? If not, can you boot with the Ubuntu CD?
    /IMHO
    //got nothin'
    ///this use to look better

  11. #10
    Just Joined!
    Join Date
    Aug 2005
    Location
    Central Canada
    Posts
    29
    Code:
    Disk /dev/hda = 80.0 GB, 80060424192 bytes
    255 Heads, 63 sectors/track, 9733 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
    [Device] [Boot] [Start] [End] [Blocks] [ID] [System]
    [/dev/hda1] [*] [1443] [9328] [63344263+] [7] [HDFS/NTFS]
    [/dev/hda2] [] [256] [1442] [9534546] [83] [Linux]
    [/dev/hda3] [] [1] [225] [2048256] [82] [Linux swap]
    
    Partition table entries are not in disk order
    The square brackets were not there I just formatted so it would be easier to see.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •