Find the answer to your Linux question:
Results 1 to 2 of 2
Hi.. I just installed RH9(gnome) and i opted for a text login. during the installation i didn't come across anywhere where i should have entered my user name....all that was ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2003
    Posts
    16

    a coulple of questions about log-ons!


    Hi..

    I just installed RH9(gnome) and i opted for a text login.

    during the installation i didn't come across anywhere where i should have entered my user name....all that was asked for was my root password.....now when i get to the text login...i have to use the user name 'root' to log in and my home folder is 'root's home' ...now this is not wat i want .....can anyone plz tell me how to change this so i don't log in as root? (its also not good for security reasons).

    also when gnome starts up i get an error something along the lines of....

    gnome could not log in tcwer1.dyn.monash.edu.au this could be fixed by putting entering it in /etc/hosts then i have the options "try again" or log in "anyway"....(or something).

    I'm on a university network.....so this has probably got something to do
    with it....my internet still works.

    also when i log in at the text login (as root at the moment!) i get teh following [root@tcwer1 root]# why is it @tcwer1 ?? this is by monash university username ???? i didn't enter it anywhere duing teh installation......can i remove it??? or change it....and how would i do this?

    cheers! .....any help/suggestions much appreciated...

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Add a user with the useradd command, and then set the password with passwd, something like this:
    Code:
    useradd -mg users stagnant7
    passwd stagnant7
    As for the GNOME and DNS problem, it seems to be because the DHCP client sets your hostname. Did you give the system a proper hostname (proper=not localhost or localhost.localdomain) when you installed RH? If not, enter one by adding HOSTNAME=whatever to /etc/sysconfig/network.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •