Find the answer to your Linux question:
Results 1 to 4 of 4
First, I hate windows. Second, can you prevent it from changing the boot flags of the various partitions on your hd? Third, I'll keep on searching the posts for the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Location
    :noitacoL
    Posts
    51

    Window changes the boot flags, argh.


    First, I hate windows. Second, can you prevent it from changing the boot flags of the various partitions on your hd? Third, I'll keep on searching the posts for the answer, but since I haven't found it in the first 20 minutes, I thought I'd post.

  2. #2
    Just Joined!
    Join Date
    Jul 2005
    Location
    :noitacoL
    Posts
    51
    Well, I got around this problem temporarily by creating a simple grub boot floppy following these simple instructions; it took about 5 minutes. Now, I leave the floppy in all the time and grub loads from it which increases my boot time (to get to the grub menu) by about 5-10 seconds. Not the ideal situation, so I'm still looking for feedback.

  3. #3
    Linux Engineer
    Join Date
    Jan 2005
    Location
    Chicago (USA)
    Posts
    1,028
    Use cfdisk or similar to toggle the bootable flag on a partition.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2005
    Location
    :noitacoL
    Posts
    51
    I'm sorry, I didn't state my problem clearly. I do use fdisk (or cfdisk) to toggle the flags, but then when I load windows (which is on the second partition) it changes the flags: it unflags my first (/boot partition) and flags the second (windows partition). It happens every time I load windows. With the floppy booting first, however, I circumvent the problem for now, cause it doesn't matter which one is flagged.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •