Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
So here's my situation, I haven't been able to find any help on after numerous searches. I have an SATA hard drive. First I had 2 partitions both NTFS (each ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    8

    Lost NTFS on xp parition of dual boot


    So here's my situation, I haven't been able to find any help on after numerous searches.

    I have an SATA hard drive. First I had 2 partitions both NTFS (each taking up a 1/3 of my hard drive, the 3rd being for my future linux install). I installed ubuntu on the 3rd partition, went thru the install did the auto setup of partitions for the free space I had leftover (the space that WASN'T ntfs)...installed grub not in the MBR. Not in the mbr because I ended up having the problem with "error no os" deal. So I not have my linux up and running, but now I try to get into XP and I get the "don't have hal.dll" deal. Yes I know there's tons of threads up about this, and I've tried to work with them except I'm having a unique experience here. When I do the Windows install cd and go into recovery console and check out my drives with MAP I'm seeing that of my previous 2 partitions on my hard drive that were ntfs (one with windows installed on it), only one is now saying formated ntfs and the other is blank or not recognized. The bad part here is that this is the partition to which windows is installed, so as far as I have seen, I haven't not figured out a way to expand hal.dll or better yet even read my drive. When installing linux I never touched that partition so I'm not quite understanding whats going on here, if it's the mbr or what. Please help! I know everything is still there on the hd but I just want to be able to access it.

    Thanks ...Shaina

  2. #2
    Just Joined!
    Join Date
    Aug 2005
    Posts
    8

    Update

    Last night I was playing around and I'm seeing that my partition w/windows on it that is supposed to be NTFS is reporting "primary boot sector invalid" Does this mean something in the partition table is amiss???

    From what I've looked at...I've seen people trying fixboot or fixmbr from Windows recovery console, but that might ruin my partition (if it's not already) ...or getting the backup mbr and restoring that. From all that and other threads I haven't found anything that's a good idea.
    thanks

  3. #3
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    Are you able to see the second partition under linux?

  4. #4
    Just Joined!
    Join Date
    Aug 2005
    Posts
    8
    yes but I can't mount it

  5. #5
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    What is the exact error you get when trying to mount it?

  6. #6
    Just Joined!
    Join Date
    Aug 2005
    Posts
    8
    mount: can't find dev/sda5 in /etc/fstab or /etc/mtab

  7. #7
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Can you mount with this:
    Code:
    sudo mkdir /mnt/sda5
    sudo mount -t ntfs /dev/sda5 /mnt/sda5
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  8. #8
    Just Joined!
    Join Date
    Aug 2005
    Posts
    8
    Here's what I get

    mount: wrong fs type, bad option, bad superblock on /dev/sda5,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so[/code]

  9. #9
    Just Joined!
    Join Date
    Aug 2005
    Posts
    8
    dmesg | tail gives me:

    ...
    NTFS-fs error (device sda5): read_ntfs_boot_sector(): Primary boot sector is invalid.
    NTFS-fs error (device sda5): read_ntfs_boot_sector(): Mount option errors=recovery not used. Aborting without trying to recover.
    NTFS-fs error (device sda5): ntfs_fill_super(): Not an NTFS volume

  10. #10
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    I know this is not good news, but I think that partition may be damaged, if both linux and Windows are complaining about it, partcularly "NTFS-fs error (device sda5): read_ntfs_boot_sector(): Primary boot sector is invalid". I would try looking at it with a partition manager like QTParted, and seeing if it can be worked on even as a raw partition.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •