Find the answer to your Linux question:
Results 1 to 3 of 3
hi i have just tried ot install on my system a copy of redhat 6.0 which i have had for a few years. i have 2 hard drives, a 40gb ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2003
    Posts
    6

    redhat fisrt run error


    hi

    i have just tried ot install on my system a copy of redhat 6.0 which i have had for a few years. i have 2 hard drives, a 40gb one and a 30gb one. after repartitioning about 5 times and installing redhat countless more, i have finally got everything to install without problems and have got lilo working. i dont know about newer versions but lal that stuff about redhat being good for newbies and first itme computer users is a load of crap. i had to spend 2 days re partitioning my harddrives and changing boot managers to finally get it to install, show me one computer illiterate person who is capable and willing to do that.

    anyway, enough rambling. i now have a 30gb partition on my first drive with xp, the rest is free, the second drive has i beleive a 70mb swap partition and a 8gb native partition. the rest is free. now finally after getting that all instaleld whenever i try and actualyl boot linux it comes up with a message saying something liek "kernel panic: cant mount host: cant read host fs" or something. basically i gather its saying it cant read the file system of the host partition IT JUST FORMATTED 5 MINUTES AGO. i would appreciaite any help since i really would liek to get it working.

    thanks

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    You might want to try a later version instead; 6.0 is really old. The earliest RH version that I can recommend is 7.1, but if your computer isn't too old, just go with 9.

    However, if you want to get this installation working, you will hvae to post how you partitioned the hard drive, and what partitions are in the extended partition and so on. My guess is that the installation program simply specified the wrong partition to of the root filesystem to the boot loader.

  3. #3
    Just Joined!
    Join Date
    Sep 2003
    Posts
    6
    the exact error i get is

    VFS: cannot open root device 00:34
    Kernel panic: VFS: unable to mount root fs on 00:34

    originally i wnated to install it on the first drive but then lilo doesnt work if its after cylinder 1024 or something so i deleted those partitoions on the first drive and now it just had a 30gb XP fat32 partition and the rest is unused. when i did a custom installation fdisk tells me i have a extended partition (patition 1) from cylinder 1 to cylinder 9 then a primary linux native partition from cylinder 10 to wahtever (its 8gb worth) then a linux swap partition starting from the first cylinder after that and going for 8 cylinders (or about 70mb) is the swap partition suppsoed to take up the same space as the extended one? those are the only partitions i have.

    i have also tried a workstation installation that worked fine where it does it all itself on a blank drive but i get exactly the same error

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •