Find the answer to your Linux question:
Results 1 to 7 of 7
OK, Many apologies if this problem has arisen before but I'm simply out of luck getting FC4 to boot from a USB drive. The problem: Booting GRUB from USB drive ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2005
    Posts
    4

    Fedora Core 4 GRUB issue


    OK,

    Many apologies if this problem has arisen before but I'm simply out of luck getting FC4 to boot from a USB drive.

    The problem:
    Booting GRUB from USB drive shows the 'GRUB' and a flashing cursor. That's it. Everything stops, no errors, no warnings etc.

    My setup:
    External USB HD
    Partitioned with 200meg (ext2) /boot partition (on sda1)
    10gig (reiserfs) / partition (on sda2)
    Rest is empty

    My motherboard is able to boot from USB as I have successfully booted Slax from a USB pen (live cd image). I guess that doesn't have grub.

    Initially I attempted to install FC4 on one partition with GRUB going on the MBR of SDA1, next I partitioned as above (separate /boot and / partitions).

    What I did so far is follow instructions below:
    http://www.linuxforums.org/forum/top...tml&highlight=
    I am able to boot into linux rescue mode and mount the usb drive. I attempted to run the root commands directly into the GRUB shell i.e. root (hd0,0) root (hd1,0) etc etc but all I get is Error 12 (device not recognized)...

    Was able to create a new initrd and added to grub.conf.
    Changed grub.conf to point to new img.
    See my most recent grub.conf below:

    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE: You have a /boot partition. This means that
    # all kernel and initrd paths are relative to /boot/, eg.
    # root (hd1,0)
    # kernel /vmlinuz-version ro root=/dev/sda2
    # initrd /initrd-version.img
    #boot=/dev/sda1
    default=0
    timeout=5
    splashimage=(hd0,0)/grub/splash.xpm.gz
    hiddenmenu
    title Fedora Core (2.6.11-1.1369_FC4)
    root (hd0,0)
    kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=/dev/sda2 rhgb quiet
    #initrd /initrd-2.6.11-1.1369_FC4.img
    initrd /usbinitrd.img
    title Other
    rootnoverify (hd0,1)
    chainloader +1


    Still I get the GRUB text in top left corner and a flashing cursor.

    Please anyone have any ideas??

    And I don't want GRUB on my main hd MBR so that's not an option though it could actually work.

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    grub comes in two parts (stages). The first part normally lives on your mbr, and this either 1) passing control onto stage2 (or sometimes stage1.5) which lives in the /boot/grub/ folder. or 2) If it can't pass on control, it leaves you in grub command mode ("grub" with a flashing cursor). From here you can manually tell grub where the various files are and get it to boot linux (or Windows) for you. Have a look at the "Solving boot problems with grub" post in the general tutorial section.

    As to why it's doing this, sorry, don't know.

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Just Joined!
    Join Date
    Aug 2005
    Posts
    4
    Quote Originally Posted by Nerderello
    grub comes in two parts (stages). The first part normally lives on your mbr, and this either 1) passing control onto stage2 (or sometimes stage1.5) which lives in the /boot/grub/ folder. or 2) If it can't pass on control, it leaves you in grub command mode ("grub" with a flashing cursor). From here you can manually tell grub where the various files are and get it to boot linux (or Windows) for you. Have a look at the "Solving boot problems with grub" post in the general tutorial section.

    As to why it's doing this, sorry, don't know.

    Nerderello
    No, sadly I don't get to the GRUB shell. It's just a frozen GRUB with a flashing cursor i.e. can't type anything.

  4. #4
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    sorry, that's all I had.

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  5. #5
    Just Joined!
    Join Date
    Sep 2005
    Posts
    1

    Same problems

    Hello, I am having identical problems that you are having. FC4, usb hard drive. I did have success with FC2 booting on the same usb hard drive. But I upgraded to FC3, and it quit working. Then I upgraded to FC4 when it came out, hoping it would work. It doesn't. So I went through the steps at simonf or benusa websites like you indicated. I have the same symptoms, freezes at GRUB screen.

    The only thing I haven't tried yet is making a bootable cd-rom with a grub shell so I can try to boot that way... But I am not too optimistic because no one has been able to tell me really what the problem is. Also, no commands to install grub work from the grub shell anyway. It's like grub can't recognize the usb device for some reason.

    I did read a rumor that if your BIOS reports different drive dimensions than linux, that during grub installation it might get the linux values instead of BIOS, and apparently 'all hell can break loose'. https://www.redhat.com/archives/fedo.../msg00206.html

    Let me know if you find a solution, I will do likewise.

  6. #6
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    I think nerderello is on target. If you can create a new partition on that drive which has the untouchable MBR and then write your kernel and initrd along with the needed /grub subdirectory with stages 1.5 and 2 as well as grub.conf to the new partition on the drive with the untouchable MBR, making sure that grub.conf includes in the 'kernel' statement the phrase root=/dev/yourUSBdrive, you could then reinstall Grub to the USB device, pointing to the /boot partition on the drive with the untouchable MBR and perhaps it might work. Or you could write a bootable Grub floppy to boot to.

    .........................................no guts, no glory
    /IMHO
    //got nothin'
    ///this use to look better

  7. #7
    Just Joined!
    Join Date
    Sep 2005
    Posts
    1

    Found solution to similar problem...

    Hi. I'm new at linux, and I was recently suffering from the same problem, but I was installing FC4 onto a regular hard drive. I also tried to install the older RH7.3 (with LILO insted of GRUB), but it booted in the same way: LILO and a flashing cursor which you can't type at.

    I decided to install my ATA/100 PCI card. The computer I'm working on is a Pentium II, so it doesn't have the full capabilities of ATA/100 on its onboard IDE controller (but the hard drive does). After I installed the card, it booted fine, except that I had to reinstall FC4 because the kernel didn't like the hard drive suddenly changing from hda to hde.

    I'm not sure why this works, but it does. It might be something to do with GRUB and anaconda (linux installer) detecting the IDE (or USB) drive settings, drive speeds, etc., differently and therefore causing a freeze on boot.

    Hope this helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •