Find the answer to your Linux question:
Results 1 to 4 of 4
(If this question has been answered before, I'm sorry, but I ran a search and the topic didn't come up.) In a nutshell, GRUB can't detect my WINXP partition, but ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    3

    RH7.3 and WINXP: GRUB can't load WINXP


    (If this question has been answered before, I'm sorry, but I ran a search and the topic didn't come up.)

    In a nutshell, GRUB can't detect my WINXP partition, but I don't think it's as simple as modifying the boot.conf file.

    Here's a more detailed explanation:

    I have a 40GB hard disk: 25MB for WINXP (15 for OS and programs, 10 for files only) and 15MB reserved for LINUX. Previously, I was dual booting WINXP and Fedora Core 3, and then I changed to Redhat 9 and then down to Redhat 7.3. (If you're wondering why I'm downgrading, I just want to install a program that runs on older versions of Redhat).

    Just recently, before installing RH7.3, I got another 3GB from my remaining space and formatted it as FAT32.

    Anyway, both FC3 and RH9 worked fine, but come RH7.3, everything went whack! I don't know if it matters, but I din't create a separate partition for /boot. I didn't create one in FC3 or RH9 before, so I thought this should be okay.

    What I think matters, though, is that I wrote GRUB into the MBR. I don't know if this is what I did with RH9 and FC3, but I never booted from the GRUB command line before, so I'm assuming that I did write GRUB into the MBR previously.

    I booted the PC and GRUB loaded just fine. It presented me with options whether to run Redhat or DOS (which I assume to be WINXP). I chose DOS and to my surprise, the PC just restarted again! O_o So okay, I ran LINUX and looked for the boot.conf file. It showed something like this:

    title DOS
    rootnoverify (hda0,5)
    chainloader +1

    This is weird because WINXP is on hda1, not hda5. hda5 actually contains the 3GB of FAT32. So I edited the boot.conf so it would read (hda0,1) instead of (hda0,5). I rebooted, and chose DOS. I was then faced with a black screen quoting the boot.conf file.

    title DOS
    rootnoverify (hda0,1)
    chainloader +1

    O_o I decided to boot from my WINXP CD just to check if my files were still intact, and they are. I also decided to delete the FAT32 partition (nothing was written on it anyway). I rebooted again, this time with the RH7.3 installer. I wanted to reinstall 7.3, this time with every intention of creating a /boot partition, and setting the default to Windows (which I didn't do before).

    HOWEVER, when I reached the part where I could select my default boot image, I was presented with the following options:

    [ ] /dev/hda1 ntfs (my 15GB winxp partition)
    [ ] /dev/hda5 ntfs (my 10GB ntfs partition)
    [/] /dev/dha7 ext3 (Redhat linux)

    I deselected Redhat and tried to select winxp. TRIED, but I couldn't. And now I'm stuck. So here are my questions because I don't know what to do anymore! I've already done a dual boot of winXP and 7.3 before, so I don't know what I did wrong this time.

    1. Is my WinXP dead? I don't think so, but it might as well be if I can't load it.

    2. Is there a way of making GRUB detect my WinXP?

    3. If I want WINXP to boot, even without 7.3. Is it safe to use FIXMBR? I've done some online searches, and everyone says to use this, but a friend of mine told me that FIXMBR deleted EVERYTHING. Will FIXMBR delete my files?

    4. Is there a safe way of uninstalling 7.3 rather than just deleting its partitions using the WINXP CD? When I changed from FC3 to RH9, I simply deleted the partitions, so when I decided to change from RH9 to RH7.3, I just deleted the partitions again. Do you think this affected my system somehow?

    You guys don't have to answer all the questions... Just please suggest a nice solution for me... Please? Even if it goes something like "you can't save windows, you've lost your files forever, you're stupid for doing what you did..." Anything! At least I know that I'm stupid and that I won't do these things again!

  2. #2
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    The line where you have hda0,1 should be /dev/hda1

    Fixmbr will do just what the command says. It is a windows tool that will put a windows bootloader on the mbr and grub will be gone.

    For Q4, if you want, you can just delete the partition that it is on and do Fixmbr from the winxp cd.
    That will get rid of RH7.3 and put ntldr back on the mbr.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  3. #3
    Just Joined!
    Join Date
    Sep 2005
    Posts
    3
    Quote Originally Posted by budman7
    The line where you have hda0,1 should be /dev/hda1
    So should my boot.conf read:

    title DOS
    rootnoverify (/dev/hda1) //should the parentheses be there?
    chainloader +1

    Thanks for the reply. Hope you can still put up with me.

    Btw, I tried booting from the GRUB command line

    rootnoverify (hda0,0)
    chainloader +1
    boot

    but it still didn't work. Is my case a hopeless case now?

  4. #4
    Just Joined!
    Join Date
    Sep 2005
    Posts
    3
    Already got it fixed. Thanks anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •