Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, I've been trying to upgrade from Mandrake 9.1 to 9.2 by using urpmi, but have run into a problem. So far i've added the proper sources then do something ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2003
    Posts
    3

    Upgrading Mandrake with urpmi


    Hi,

    I've been trying to upgrade from Mandrake 9.1 to 9.2 by using urpmi, but have run into a problem. So far i've added the proper sources then do something such as:

    urpmi kernel

    It finds the packages and asks about dependecies, etc., but as soon as it tries to download anything i get a long string of errors like

    ==> fdClose(0x8d8a43 rc fffffffe | FD -1 fp (nil)

    and then it says

    perl: rpmio_internal.h:447: c2f: Assertion `fd && fd->magic == 0x04463138' failed.

    I really have no clue what do now. I was hoping someone here might have tried this process too or might be able to help. Thanks

  2. #2
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496
    Never used Mandrake myself, but a quick google turned up the following:

    I got the same problem a few times, but I can't exactly remember how I
    recovered from them.

    Each time it happened because I interrupted a long process of upgrades
    through urpmi.

    I guess this is a problem of little-endian/big-endian mismatch somewhere
    because I never had this issue with x86.

    Anyway, try to rebuild your rpm database a few times, it might help to
    solve the problem:

    $ rpm --rebuilddb

    Also try to upgrade (by hand) urpmi and its dependencies (perl-URPM,
    rpm...), and rebuild the database with the new tools.
    The cooker version I run seems to be immune to this problem...

    I hope this will help you,
    Regards,

    --
    Brice
    \"Everything should be made as simple as possible, but not simpler.\"
    Albert Einstein

  3. #3
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    I upgraded from 8.2 to 9.0 by shoving in the distro discs and selecting 'upgrade'.

    Seemed a lot easier than using urpmi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •