Find the answer to your Linux question:
Results 1 to 6 of 6
I am a nebie to linux and am trying to install onto a brand new machine. I have tried Debian, Ubuntu and Fedora Core 4, all AMD64-bit versions. Everyone of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    4

    GRUB hangs in all distros - please help


    I am a nebie to linux and am trying to install onto a brand new machine. I have tried Debian, Ubuntu and Fedora Core 4, all AMD64-bit versions. Everyone of them boots up and hangs at GRUB loading. It certainly seems to me that this there is a common problem here in all attempts. And I am surprised that there is not more info on this problem if I am having it in all distros. Is it my Raid setup or is it something else, maybe BIOS? Maybe more explicit instructions for getting to and looking at grub setup. Please help.

    My system:
    MSI K8N Neo 4 Platinum mobo
    AMD Athlon 64 3700+ processor
    2-160 GB WD SATA HD in raid0
    1 GB RAM
    ATI Radeon X300SE Video Card, 256MB HyperMemory

  2. #2
    Linux User Game master pro's Avatar
    Join Date
    Sep 2005
    Location
    Tasmania, australia
    Posts
    274
    I really wouldn't know, but have you tried using LILO instead?

  3. #3
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Grub Manual

    So where, exactly does Grub hang? My understanding of Grub is as follows (although the link above may have more to say):
    1. BIOS boots hardware and then hands control to the MBR of the boot device.
    2. The MBR only points to the partition where the main Grub files are. If those files cannot be found, I think that booting will hang with "GRUB_" with the last character flashing.
    3. Grub looks in the boot partition (I think it searches the top directory in that partition, as well as /boot and /grub subdirectories) to find the files 'stage1', 'stage2' and the "correct" '*_stage1_5'. I think the message 'Grub loading.....' happens during the loading of those files.
    4. Once the Grub files are loaded, Grub looks for the file 'grub.conf' or 'menu.list' which links to 'grub.conf'. If 'grub.conf' is not found, booting is suspended with the Grub command prompt "grub>" where commands may be entered manually to continue booting or to install Grub, etc.

    Error messages reported by GRUB

    .
    /IMHO
    //got nothin'
    ///this use to look better

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2005
    Posts
    4
    I think the problem is the RAID. I aslo have such problem before, when I turn off RAID in the BIOS, the bootloader works and linux can start up.

    Anybody know why the Fedora couldn't run on the RAID system?

  6. #5
    Just Joined!
    Join Date
    Sep 2005
    Posts
    4
    Well, I think it is/was the Raid as well. The BIOS had as a boot preference option on the HD of the Raid striping of the 2 HDs only. I ended up going to "Load Optimal defaults" or something similar. This changed the HD boot preference option to include either drive 1 or 2, and with the striping option no longer available. After such, no problem getting Debian 3.1r0 and Fedora 4, both AMD64 versions, to run.

    I also saw some refereence that the problem appeared to be that a connection was loose or something, and this was a real possibility especially due to the fact my new machine needs a new case after its ride on UPS. But averything else seems to be running fine. Finally, I went with the reload defaults in BIOS option. Very little if anything else changed other than the Raid striping prefence in the HD boot order options. So I concur, it is the Raid. Settled with Fedora 4 here for now, and running Raid0 as well.

    A last gathering of thoughts. It appears that the SiL 3114 SATARaid driver still loads first (must be in MBR?), followed by the nVidia CK804 driver. The raid striped drives are then seen as healthy, prior to loading linux it would also appear. Only the fact that the BIOS would see them as striped in the HD boot preference seems to have kept it from booting through. And the only way I could apparnetly change that was to load optimized defaults. Just still not quite sure why the BIOS couldn't be altered correctly.

    Anyways, away we go,

    Thanks

  7. #6
    Just Joined!
    Join Date
    Dec 2007
    Posts
    1

    Thank you!

    I found a similar problem in my BIOS.
    I'm using a Dell Precision 390

    It turns out, that when I added a drive to the IDE slave position, I needed to also turn on PATA-1 in the BIOS. I didn't realize this was an issue.

    What is especially weird: how did I install fedora core 8 to the PATA-1 drive if it was turned off in the BIOS????

    whatever... turning it on fixed this problem for me.

    After looking into several forums and then seeing the resolutions, I can agree that if you see the "GRUB" and then a cursor but the GRUB accepts no input... you probably have a drive configuration problem in BIOS.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •