Find the answer to your Linux question:
Results 1 to 3 of 3
Back again with yet another question....I was trying to install Wuftp, and they say that I should use the realpath.patch. Now how do I install it, or plug it in? ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2005
    Posts
    16

    Trying to Install Wuftp...


    Back again with yet another question....I was trying to install Wuftp, and they say that I should use the realpath.patch. Now how do I install it, or plug it in? What exactly can I do with a .patch file? If anybody could tell me, that would be awesome. This might help - the website I'm refering to is www.wu-ftpd.org. Also, when I'm installing wuftpd, it gives me this error:
    Code:
    root@1[wu-ftpd-2.6.2]# ./build install
    
    IMPORTANT NOTICE
    
    Beginning with version 2.6.0, the WU-FTPD Development Group is moving the
    build process to use GNU Autoconf.  Until this move is completed, both
    build systems will remain supported.  You are encouraged to use the new
    "configure" command to select options, then "make" to compile the daemon.
    For details on this, read the README.AUTOCONF file.
    If problems occur, please report them to the development group via email to
    wuftpd-members@wu-ftpd.org  We are soliciting feedback on the new
    configuration process, and your help is greatly appreciated.
    
    If you choose to continue to use the original build process, bear in mind
    it will be phased out over the next few releases: when we are reasonably
    sure the new configuration system works for most target platforms.
    
    Sleeping for five seconds, sorry for the interruption.
    make args are :
    make opts are :
    make: *** No rule to make target `bin/ftpd', needed by `install'.  Stop.
    Now, I don't know if this is related to the realpath.patch issue...but if someone could help me out, it would be much appreciated. Thankyou!

  2. #2
    Just Joined!
    Join Date
    May 2009
    Posts
    3

    I have the same problem...

    I encounter the same problem, if anyone has the answer!

  3. #3
    Linux User
    Join Date
    May 2009
    Location
    Big River, Sask, Canada
    Posts
    342
    List of FTP server software - Wikipedia, the free encyclopedia says that wu-ftpd has security problems. If the patch fixed that, then it may be okay to use, otherwise I would use one of the other options.
    The error would appear to be something missing in the makefile, namely the target file /bin/ftpd
    Registered Linux User #420832

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •