Find the answer to your Linux question:
Results 1 to 4 of 4
Hi I have recently set up a new installation of Red Hat 7.3 to play with as I get the time. I already have an E-smith machine running as a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2003
    Posts
    8

    Network Setup


    Hi

    I have recently set up a new installation of Red Hat 7.3 to play with as I get the time. I already have an E-smith machine running as a gateway to 2 Windows machines, which is all A-OK. Originally when I set up my new RH installation I had it running across my network no probs. But as I have not been able to play with it for several weeks I shut it down as it's not the newest of hardware and the fans starts playing up after a while.

    Anyway, since starting it again I've not been able to see it across my network. I have my E-smith machine set to 192.168.0.1 acting as a server and gateway and it controls DNS across the network. The Red Hat box in question is, supposed, to be set at 192.168.0.4. However when I go into "setup" and go to Network configuration I enter the following details:

    IP: 192.168.0.4
    Netmask: 255.255.255.0 (same as all the other machines on the network)

    After setting these it automatically loads the following:

    Default Gateway: 192.168.0.254
    Primary Nameserver: 192.168.0.1

    I have set the Default Gateway to 192.168.0.1 - as I assmue this is the correct setting. But I've also tried leaving it at 192.168.0.254

    The strange thing is that after I have made these changes the next time I go back to Network Configuration all these details are empty and the Dynamic IP is unchecked.

    The other thing, which I am not sure if it is connected, is that I cannot set the firewall to anything but "High", it just defaults back to High next time I enter the firewall setting. Its as if the settings in setup just aren't working. I am logged on as root.

    Anyway, all help is greatly appreciated.

    Cheers

  2. #2
    Linux Engineer
    Join Date
    Apr 2003
    Location
    Sweden
    Posts
    796
    Those X-programs sucks.. open a terminal instead switch to the root-user.

    Edit /etc/sysconfig/network to this

    Code:
    NETWORKING=yes
    HOSTNAME=yourhostname
    and /etc/sysconfig/network-scripts/ifcfg-eth0 to this

    Code:
    DEVICE=eth0
    BOOTPROTO=static
    ONBOOT=yes
    IPADDR=192.168.0.4
    NETMASK=255.255.255.0
    GATEWAY=192.168.0.1
    FORWARD_IPV4=no
    Then restart your network with /etc/init.d/network restart

    Verify with ifconfig that you have set your new ipadress, try to ping your gateway and other windows boxes..
    Regards

    Andutt

  3. #3
    Just Joined!
    Join Date
    Jan 2003
    Posts
    8

    OK

    Thanks heaps for the help andutt

    I tried doing all those things, and everything was basically in the right place, unfortunately though it's still not up and running. One thing I did notice is that when I run ifconfig it has the following line in it:

    inet addr: 192.168.0.4 Bcast: 192.168.0.255 Mask: 255.255.255.0

    I am not sure what the "Bcast" means, and is it correct?

    Also, in all this I haven't seen a DNS setting. My E-smith machine handles DNS for the network, could this be the problem?

    Cheers!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Mar 2003
    Posts
    84
    bcast mean the broadcast address and it should be the last address in ur ip range
    plus use the ifconfig to set up the ips of ur linux machin

    -Dewey-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •