Find the answer to your Linux question:
Results 1 to 7 of 7
Trying to install Fedora Core 4. On a 2.8 GHz P4 w/ 512MB RAM, 160GB Maxtor HDD. I can only get to the point where you select keyboard layouts. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    8

    Error during installation


    Trying to install Fedora Core 4. On a 2.8 GHz P4 w/ 512MB RAM, 160GB Maxtor HDD.

    I can only get to the point where you select keyboard layouts. I select U.S. English, then it hangs for a while and I get an error message reading: "Input/output error during read on /dev/hdc". From what I gather, this is a hard drive error? I am running in Knoppix right now to type this message as I have already deleted my Windows partition (I intended to make this a dedicated Linux machine).

    I have successfully installed Linux before on several computers (Mandrake 10.1, Fedora Core 3, Red Hat 6 being a few) without any trouble (well at least not too much trouble).

    I can't access the hard drive from Knoppix, I assume that's because it has no partitions on it? I tried to partition it using QTParted, and I am able to create a swap partition and an ext3 partition without any trouble, but when I go back to install FC4, I get the same message.

    I'm kind of at a loss as to what to do here. I'm going to look around and see if I can find my old Fedora Core 3 discs around and see if those will install (I successfully installed it on this machine before). Any suggesstions would be appreciated.

    Thanks,
    Nick

  2. #2
    Linux Engineer
    Join Date
    Oct 2004
    Location
    Vancouver
    Posts
    1,366
    Looks more like it might be a problem reading the cd, did you check the integrity of the iso or run media test...
    Operating System: GNU Emacs

  3. #3
    Just Joined!
    Join Date
    Nov 2004
    Posts
    8
    Yes I tested all 4 discs and they all checked out fine. If it was an error reading the cd, then why would it give me an error message on /dev/hdc, which is my hard drive?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    /dev/hdc is the master on the 2nd ide bus. /dev/hda is the master on 1st ide bus. So, unless your hard drive is connected to the 2nd ide channel as master, you shouldn't get that problem.

    But, if your hard drive is connected to 2nd ide bus, either try connecting it to the 1st ide bus as master and seeing how it goes, or leave it on the 2nd ide bus and use QTparted to create the partitions for fedora to install to.
    Life is complex, it has a real part and an imaginary part.

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Posts
    8
    I'm pretty sure my hard drive is on the primary ide bus. I will open up the case and check though. In Knoppix, my hard drive is listed as /dev/hdc though, so maybe there is a chance that I connected something wrong last time I had the case open.

    I have tried using QTparted to create the partitions, but still get the same error message when trying to install FC4. I'll check which bus it's connected to and switch it to the primary if it isn't already there and see how that goes.

    Thanks,
    Nick

  7. #6
    Just Joined!
    Join Date
    Nov 2004
    Posts
    8
    Hi,
    Just wanted to let everyone know that AlexK was right. I must have switched the primary and secondary ide cables last time I had the case open for some reason. In Windows, I guess it didn't really matter much, but apparently it was causing a problem with accessing the hard drive during my install. I don't know if this is a common issue with Fedora Core 4 or Linux in general, but I guess it's something good to know for noobs like me . As soon as I switched the cables, the install went flawlessly.

    Thanks for your help.

    Nick

  8. #7
    Just Joined!
    Join Date
    May 2007
    Posts
    1

    Thumbs down Input/output error during read on /dev/hda

    I had my hard disk connected to the 2nd IDE channel as master with the DVD-ROM connected as a slave, the message I got during first steps of installation process was "..error during read on /dev/hdc". As suggested by Alex,
    I connected my hard disk to primary IDE channel but the result was only that the error message reported " error during read on dev/hda" instead of "hdc"; I also tried to change DVD-ROM jumper configuration and connect it on the secondary channel, but it didn't work...

    Hope someone can help

    thanks

    P

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •